Highlighted
Enthusiast
Enthusiast

Enhanced authentication plugin not working

Hi all - have VCSA 6.5 installed in two locations now.  Enhanced authentication plugin is installed but not working - cannot check the box for credential fill-in.  Tried a few different things to no avail.  Anyone have it working or know why it may not be working in Chrome or IE in Windows 10?

Thanks all!

24 Replies
Highlighted
Contributor
Contributor

we have the same issue, even tried a fresh installation on a new pc, just to test this out

0 Kudos
Highlighted
Contributor
Contributor

I have the same issue, Chrome, IE and Edge, none of them work. I had the previous 6.0 CIP installed and tried un-installing that but no change.

0 Kudos
Highlighted
Contributor
Contributor

I got it working by uninstalling all other vmware client plugins and fat client.  Works every time for my account that is a local administrator of the desktop, however if I login as a standard user, it stops working.

0 Kudos
Highlighted
Contributor
Contributor

Having the same issue.  Trying to access in my test environment (brand new install of everything, including domain) from a Server 2016 RDS host.  Installed the plug ins.  Refreshed browser, rebooted, even reinstalled.  There is no fat client installed.  No other plugins.  Box remains grayed out.

0 Kudos
Highlighted
Contributor
Contributor

So something I found today was the service that installs with the plugin was not starting even though it was set to start Automatically.  Service is called VMware CIP Message Proxy Service.  I changed startup type to Automatic (delayed start) and it's working for me now.

Highlighted
Enthusiast
Enthusiast

I have the same issue, IE and Edge don't work, Firefox does.  CIP service is running fine.  Plugin does not show up in manage add-ons.  Can't find manage add-ons in Edge.

Old enough to know better, young enough to try anyway
0 Kudos
Highlighted
Contributor
Contributor

Was facing the same exact issue.

This is how I resolved:

1. Login to the client machine using an account with Administrative privileges.

2. Browse following location:

C:\Program Files (x86)\VMware\Enhanced Authentication Plug-in 6.5

3. Locate following registry file: WindowsAuthKey_x64 or WindowsAuthKey_x86 depending on OS being 64-bit or 32-bit.

4. Double Click on the above file and Merge it into Registry.

5. If it fails to Merge, then try logging in with Local Administrator account and try again.

6. Launch a web-browser and test if Windows Session Authentication box is available.

7. If not, then uninstall and reinstall Enhanced Authentication Plug-in and try again.

Highlighted
Contributor
Contributor

VMware CIP Message Proxy Service was the culprit and changing to delayed start is working for me!  Thank you!

0 Kudos
Highlighted
Enthusiast
Enthusiast

It's only broken in Chrome for me.  CIP Proxy service is running fine.  I suspect a Chrome update may be the culprit - currently on version 57.0.2987.133.  ¯\_(ツ)_/¯

0 Kudos
Highlighted
Contributor
Contributor

I have the same issue but only with chrome version 58.

Reinstall or double click on above registry files not working for me.

0 Kudos
Highlighted
Contributor
Contributor

Chrome and IE no longer uses the NPAPI method. Use Firefox or something else instead. But Firefox will be removing the NPAPI as well at some point in the future.

0 Kudos
Highlighted
Contributor
Contributor

And when Firefox also removed the NPAPI future? What is the solution from VMware?

0 Kudos
Highlighted
Contributor
Contributor

I'm not an employee of vmvare Smiley Happy I hope vmvare will solve this problem.

0 Kudos
Highlighted
VMware Employee
VMware Employee

Internally we have PR reported for this issue and stated to resolve in upcoming update release i.e "vSphere 65U1".

Highlighted
Contributor
Contributor

I did the registry and it still didn't work with 2012 r2/IE11, I reinstall the plugin, it still didn't work.

I did put it on the IE11 option security/local intranet, then it work......................................................................................

crap you can't open now the gui client 6.0 with vcenter 6.5...

Highlighted
Enthusiast
Enthusiast

I have a similar issue and have found a work around that works for me and my environment. I have found that the certificate that is self-generated with the EAP plug-in is getting rejected by Chrome, you can see this if you hit F12 and look at the "Console" and "Security" tabs.

The simple work around is to manually navigate to https://vmware-plugin:8094 (your hosts file is edited as part of the installation) and select "Advanced" and "Proceed to https://vmware-plugin:8094".

This will work as long as the exception is remembered by Chrome. A better solution would be to regenerate the certificate with the appropriate missing information, but VMware is just telling everyone to wait for the next vCenter release.

Highlighted
Contributor
Contributor

None of following options worked in my case -

Used Firefox and installed plugin - restarted browser, rebooted system

KeptVMware CIP Message Proxy Service in delayed mode

Merged C:\Program Files (x86)\VMware\Enhanced Authentication Plug-in 6.5 into registry

Before doing all above, "Use Windows session authentication" was greyed out but now it is clickable. However after clicking it reports "Invalid Credentials"

While VMware is trying to fix in next release, is there any KB article for work around so far.

Highlighted
Contributor
Contributor

@tim_841: This workaround works for me. Only after a week I head to repeat these steps.

0 Kudos
Highlighted
Contributor
Contributor

Same here.

I am in a testing phase and its not going very well at all. Running 6.5 and this is already my third install on Win 2012 R2 Server.

Everytime I am faced with credentials invalid error message when using Chrome (have to use Chrome).

If I try with FF, I have no issue but the problem is with the Flash.

So now trying to use Enhanced Authentication but yet what a pain,  I am connected now but this is simply not a piece of software that I want to see in my Infra.

For that much money, I should be able to sip cocktails and see the soft creating all my VM for me Smiley Happy Probably be in Holidays somewhere around Cuba then !!

0 Kudos