mostfaleoni
Contributor
Contributor

Enable Virtual Machine Startup and shutdown

Jump to solution

Hello,

I am not Enable Virtual Machine Startup and shutdown I don't know what is reason.

Untitled.png

0 Kudos
1 Solution

Accepted Solutions
f10
Expert
Expert

Hi,

Here is the VMware KB which provides a workaround to enable this option for VMs on ESXi hosts in HA enabled cluster.

VMware KB: The Virtual Machine Automatic Startup / Shutdown feature in ESXi hosts in a VSA cluster g...

Last time (couple of years back) when I was researching about this issue, I found that the these settings are applicable only when the VM remains on the same ESXi host and once its migrated to another ESXi host the automatic startup option for that VM is lost and needs to be reconfigured again. I am not sure if this behavior has changed with the newer versions of vSphere.

Hope this helps.

-Arun

Twitter: https://twitter.com/arunpande

Blog: http://highoncloud.blogspot.in/

About VMware Virtualization on NetApp

Regards, Arun Pandey VCP 3,4,5 | VCAP-DCA | NCDA | HPUX-CSA | http://highoncloud.blogspot.in/ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".

View solution in original post

0 Kudos
10 Replies
schepp
Leadership
Leadership

Hi,

I guess it's disabled because the host you're trying to configure is part of a HA enabled cluster.

Tim

mostfaleoni
Contributor
Contributor

It is part of HA but I enabled them before while it was part of HA  enabled cluster

0 Kudos
schepp
Leadership
Leadership

Doesn't matter. When HA is enabled on a host, the Virtual Maschine startup and shutdown function is disabled as it would interfere with HA.

Tim

0 Kudos
f10
Expert
Expert

Hi,

Here is the VMware KB which provides a workaround to enable this option for VMs on ESXi hosts in HA enabled cluster.

VMware KB: The Virtual Machine Automatic Startup / Shutdown feature in ESXi hosts in a VSA cluster g...

Last time (couple of years back) when I was researching about this issue, I found that the these settings are applicable only when the VM remains on the same ESXi host and once its migrated to another ESXi host the automatic startup option for that VM is lost and needs to be reconfigured again. I am not sure if this behavior has changed with the newer versions of vSphere.

Hope this helps.

-Arun

Twitter: https://twitter.com/arunpande

Blog: http://highoncloud.blogspot.in/

About VMware Virtualization on NetApp

Regards, Arun Pandey VCP 3,4,5 | VCAP-DCA | NCDA | HPUX-CSA | http://highoncloud.blogspot.in/ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".

View solution in original post

0 Kudos
schepp
Leadership
Leadership

Arun Pandey the KB article you linked is valid for VSA clusters, not HA.  The KB even says:

Automatic start up is not supported when used with vSphere HA. For more information, see theCreating a vSphere HA Cluster section of the vSphere 5.1 Availability Guide.

Tim

0 Kudos
f10
Expert
Expert

Thanks

I misread the KB but its strange that this option is enabled in the vSphere 5.1 GA environment that I have but I see that the Availability Guide also clearly states that this option is disabled for ESXi hosts in HA cluster. Either I am lucky Smiley Happy or I probably need to check again after few hours.

-Arun

Twitter: https://twitter.com/arunpande

Blog: http://highoncloud.blogspot.in/

About VMware Virtualization on NetApp

Regards, Arun Pandey VCP 3,4,5 | VCAP-DCA | NCDA | HPUX-CSA | http://highoncloud.blogspot.in/ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos
grasshopper
Virtuoso
Virtuoso

For HA enabled clusters that need pre-defined startup order of VMs, consider using a vApp.  Here's an excellent article on how to get that going.

Understanding the Power of VMware vApps

0 Kudos
King_Robert
Hot Shot
Hot Shot

1

In the vSphere Client inventory, select the host where the virtual machine is located and click the Configuration tab.

2

Under Software, click Virtual Machine Startup/Shutdown and click Properties.

The Virtual Machine Startup and Shutdown dialog box opens.

3

Select Allow virtual machines to start and stop automatically with the system.

4

(Optional)  Configure the startup and shutdown behavior.

0 Kudos
mostfaleoni
Contributor
Contributor

Thanks all for your support and special thanks for "f10" for your correct answer

0 Kudos
f10
Expert
Expert

Thanks for the update . its very rare that I don't follow the VMware KB correctly Smiley Wink.

Regards, Arun Pandey VCP 3,4,5 | VCAP-DCA | NCDA | HPUX-CSA | http://highoncloud.blogspot.in/ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos