RazvanVladVCP
Contributor
Contributor

ESXi4.1 in Vcenter 5 vmotion problem

Jump to solution

    Hi,

I am in full process of migrating my virtual infrastructure to Vmware 5.

I have installed a new vCenter (build 455964) and I migrated all the hosts from vCenter 4.1 to my new vCenter.

I have 14 IBM HS22 Blades. We purchased the first 9 blades in 2010 and the last ones this year.

All of them are equiped with 2 x5650 six-core processors.

My problem is that I am not able to vmotion virtual machines between the new blades and the old ones even the processors are the same.

The error is: Host CPU is incompatible with the virtual machine's requirements at CPUID level 0x1 register 'ecx'. Mismatch detected for these features: *PCLMULQDQ and *AES-NI.

I can't enable EVC mode as I can't poweroff the virtual machines.

I tried to update the firmware/bios on the blades but the result was the same.

Has anyone of you encountered such a problem? Is this a vCenter bug?

Thank you,

Razvan

0 Kudos
1 Solution

Accepted Solutions
Virtualinfra
Commander
Commander

Its not bug with vcenter 4.1.

There is a feature in IBM blade server called AES (Advanced Encryption Standard). which stop performing vmotion.

you need to disable AES on new IBM HS22 blade and add that host to cluster and see vmotion will work like a charm. we had the same issue and we resolved by disbaling AES on ibm HS22 blades.

Refer the below IBM KB for the issue:

http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5086963

Award point for helpful and correct answer by clicking the below tab Smiley Happy

Thanks & Regards Dharshan S VCP 4.0,VTSP 5.0, VCP 5.0

View solution in original post

0 Kudos
8 Replies
Virtualinfra
Commander
Commander

Its not bug with vcenter 4.1.

There is a feature in IBM blade server called AES (Advanced Encryption Standard). which stop performing vmotion.

you need to disable AES on new IBM HS22 blade and add that host to cluster and see vmotion will work like a charm. we had the same issue and we resolved by disbaling AES on ibm HS22 blades.

Refer the below IBM KB for the issue:

http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5086963

Award point for helpful and correct answer by clicking the below tab Smiley Happy

Thanks & Regards Dharshan S VCP 4.0,VTSP 5.0, VCP 5.0
0 Kudos
RajuAdhinarayan
Contributor
Contributor

Hi,

My suggestion is to create new cluster in the same datacenter and remove 1 host from old cluster and add that in new cluster and enable the EVC based on that CPU compatablity . Post that try to move the powered on VM's from old cluster to the new cluster. Once this testing is completed. You can able move all the powered on VM's to New cluster.

Regards,

Raju Adhinarayanan

0 Kudos
RazvanVladVCP
Contributor
Contributor

Hi,

The same blades works fine under vCenter 4.

Unfortunately now I have a crashed blade and no space to migrate the existing virtual machines.

Tomorrow I will try the tools founded in the link you gave me.

Thank you very much and I will let you know how this will go on.

Razvan

0 Kudos
Virtualinfra
Commander
Commander

Call IBM support incase you feel diffculty in disabling the AES on New blade.

Make sure you do this on nre blade servers before you add that to cluster.

1. Update firmware to the same level what other server are there in the cluster.

2. Disable AES for vmotion issue.

YOu will go be good proceed.

Award points for the helpful and correct answer by clicking the below tab Smiley Happy

Thanks & Regards Dharshan S VCP 4.0,VTSP 5.0, VCP 5.0
0 Kudos
joemazur64
Contributor
Contributor

I have the same problem with an R710 ESXi 5.0 U1 host. I cannot vMotion to it, and the feature mismatch is given as PCLMULQDQ and AES-NI. However, I cannot disable AES in the BIOS. Anyone?

0 Kudos
RSSODC
Contributor
Contributor

Hi joemazur64

Did you ever solve your problem? Just had a board and CPU replaced in a Dell R610, and now I have the same problem.

0 Kudos
joemazur64
Contributor
Contributor

I am out of the office until Tuesday Sep 4. Please contact Romeoville IT Support with any issues.

Thanks

0 Kudos
mtsg
Contributor
Contributor

Hi, i had the exact same issue and it trying to run IBM ASU to make the changes but is unable to do so by using ESXi SSH.

Does anyone have any idea how to run ASU on ESXi?

Thanks in advance

0 Kudos