scerazy
Enthusiast
Enthusiast

Database upgrade failed (2.5U3 to 4.1)

Had my VC 2.5 U3 running on SQL EXpress 2005 on W2K3 x86

Needed to move to new hardware, so W2K8 R2 with SQL Express 2005 x64

Installed SQL Express 2005 x64 on destination detatched / attatched database, created ODBC pointing to the database, run VC 4.1 install which returned error about sql procedure failed & setup exited

Got exception: ERROR [SQL Native Client][SQL Server]CREATE INDEX failed because the following SET options have incorrect settings: 'ARITHABORT'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods.

Error while upgrading: ERROR [SQL Native Client][SQL Server]CREATE INDEX failed because the following SET options have incorrect settings: 'ARITHABORT'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods.

Info: Exiting Upgrade Wizard

Re-run the setup, but just seen the database (version must have been upgraded), ask to keep, setup finished OK, but of course VC service will not start

Is there a way to re-run just the database upgrade part?

Seb

0 Kudos
2 Replies
Troy_Clavell
Immortal
Immortal

maybe this will help?

http://kb.vmware.com/kb/1024449

0 Kudos
scerazy
Enthusiast
Enthusiast

I do not know, as I follow this:

http://communities.vmware.com/thread/277151

and setup & upgrade certainly worked this time (but needed to uninstall, detach/attach the database & re-run the setup)

As opposed to the search on VMTN (which is less than helpful, at least IMO)

Seb

0 Kudos