madda
Hot Shot
Hot Shot

Consolidation button missing

Jump to solution

I have recently installed VC and Converter Enterprise onto a server, and the VC works correctly and I get the Import Machine option when I right click on the ESX host. However I do not get the Consolidation button in the main toolbar.

I have disabled and re-enabled the plugin on the VI client and I have followed everything posted in the thread below, but I still haven't been able to get the button.

http://communities.vmware.com/click.jspa?searchID=3432601&objectType=2&objectID=980482

How can I get the button to display so that I can use the Consolidation feature?

----- Mark Atherton
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

It appears Consolidation is not enabled don't know why so I navigated to c:\Documents and Settings\All Users\Application data\VMware\VMware VirtualCenter\

and remove the following lines from the vpxd.cfg file, rebooted the VC server.

Reconnect via the VC Client and the icon should be there

View solution in original post

0 Kudos
13 Replies
ESXDevil
Enthusiast
Enthusiast

Hi

I had the same thing but after a reboot of the VirtualCenter Server all was fine.

Perhaps it works when you just restart the Infrastructure Client?

Regards

ESXDevil

0 Kudos
Texiwill
Leadership
Leadership

Hello,

Moved to VI: VirtualCenter 2.x forum.


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education.

CIO Virtualization Blog: http://www.cio.com/blog/index/topic/168354

As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XII: 2009-2020,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos
madda
Hot Shot
Hot Shot

I have restarted the client a number of times but it hasn't picked it up, I will give the VC a reboot and see if that resolves the issue

----- Mark Atherton
0 Kudos
Leafy911
Expert
Expert

The consolidation button is related to VMware Capacity Planner which is installed during the installation of VirtualCenter. You can't get this product seperately unless you are a VMware Authorized Consultant. So you will have to un-install and then re-install VirtualCenter from 'Add or Remove Programs' . You can't 'modify' or 'repair' as these options do not work.

When you have re-install VirtualCenter then you will see the following for Capacity Planner:

1) 'VMware Capacity Planner for VirtualCenter' will be in 'Add or Remove Programs'

2) 'VMware Capacity Planner Service' will be installed and running in 'Computer Management'

3) The program files will be installed in installationdrive:\Program Files\VMware\Infrastructure\VMware Capacity Planner and

the logs in installationdrive:\Documents and Settings\All Users\Application Data\VMware\VMware Capacity Planner\Logs

I hope this helps.

Regards

Leafy911

(Dont forget you recieve points when you award points)

Regards Leafy911 (Dont forget you recieve points when you award points)
madda
Hot Shot
Hot Shot

Capacity Planner is a seperate product, in ESX there is a version included which monitors fewer metrics, but works in the same way.

So I should be seeing a Consolidate button in the toolbar, but I dont at the moment

----- Mark Atherton
0 Kudos
Leafy911
Expert
Expert

Thats the same thing I wrote about, it might only be the consolidation button in VC, but it installs in the back ground as Capacity Planner. I haven't bought any additional software.

Regards

Leafy911

(Dont forget you recieve points when you award points)

Regards Leafy911 (Dont forget you recieve points when you award points)
0 Kudos
madda
Hot Shot
Hot Shot

I re-read what you said, and it makes sense now.

However it is in add/remove programs, the service exists and the log directories have been created, yet I still dont get the consolidate button in the toolbar

----- Mark Atherton
0 Kudos
Leafy911
Expert
Expert

I removed CP from Add /Remove programs and thats when I noticed the button disappeared after re-starting VC. I did this to try and loosely mimic your situation. I could find no other way to get the CP back apart from installing VC again. I tried Modify and then Repair, they didn't work. I then removed VC server (not client/Update Manager/Converter Enterprise) and then installed it again. I got the Consolidation button back. I have SQL2005 and so all my settings were still there.

Regards

Leafy911

(Dont forget you recieve points when you award points)

Regards Leafy911 (Dont forget you recieve points when you award points)
0 Kudos
madda
Hot Shot
Hot Shot

Hmmm, I tried rebooting and that didn't fix it

I also uninstalled and reinstalled the VC and all other components including Capacity Planner, however I still do not get the Consolidation button...

Any further ideas?

----- Mark Atherton
0 Kudos
admin
Immortal
Immortal

It appears Consolidation is not enabled don't know why so I navigated to c:\Documents and Settings\All Users\Application data\VMware\VMware VirtualCenter\

and remove the following lines from the vpxd.cfg file, rebooted the VC server.

Reconnect via the VC Client and the icon should be there

View solution in original post

0 Kudos
madda
Hot Shot
Hot Shot

This line was present in the cfg file, so I removed it and relaunched the VC client, but I still do not get the button.

I tried restarting, and the button magically appeared!

Thank you very much all

----- Mark Atherton
0 Kudos
Leafy911
Expert
Expert

I have disabled and re-enabled the plugin on the VI client and I have followed everything posted in the thread below, but I still haven't been able to get the button.

How can I get the button to display so that I can use the Consolidation feature?

I assumed you followed everything in this post which included editing the vpxd.cfg file

Regards

Leafy911

(Dont forget you recieve points when you award points)

Regards Leafy911 (Dont forget you recieve points when you award points)
0 Kudos
franciscoleiria
Contributor
Contributor

I didn´t delete the line, just changed the value from "true" to "false", restarted the services and FINALLY the button showed

0 Kudos