Contributor
Contributor

Cloning compact Templates to compact Templates fails

Hi,

using Virtual Center to clone a compact template to a new template, using the "compact" option sometimes does not work. I get a thick-prealocated disk instead of a thin-provisioned one. Using the console and cloning the vmdk file does work. Any ideas what's wrong?

Raoulst

0 Kudos
11 Replies
Contributor
Contributor

To be a little bit more specific:

If the cloning to a compact templates works, depends on the specific template I'm cloning from. So if it works with a template, it will always work with that template and vice versa.

Raoulst

0 Kudos
Expert
Expert

I'm confused on what you mean by a compact template? Where does that option show up when you do a clone operation?

0 Kudos
Contributor
Contributor

to clone a template:

right click the template -> clone -> enter a new name -> set the destination host or cluster -> choose the datastore -> select the format <-[/b]

that's where you select either "Normal" to get a thick-preallocated disk or "Compact" to get a thin-provisioned one.

raoulst

0 Kudos
Champion
Champion

Most issues ive seen with Templates has been cured by converting to a VM and then back to Template again..

Or failing that, convert Template to VM then clone it, then convert the clone to new Template..

0 Kudos
Expert
Expert

Thanks, I guess I never tried cloning a template before. I would go with "acr" and convert to a VM, clone, then convert to a template.

0 Kudos
Immortal
Immortal

I've had lots of issues with templates. In fact I MUCH prefer to deploy inside the VM because it is a lot faster then deploying a template. You can provision a new VM in 2 minutes vs. 10+ on a deploy.

Thomas H. Bryant III
0 Kudos
Contributor
Contributor

Converting templates to VMs and back did never help. What does work in some cases is to deploy a template to a VM and then clone it back to a template using the "Compact" option resutling in a template containing a thin provisioned disk.

0 Kudos
Contributor
Contributor

The problem is, that you don't have the option to clone to a "Compact" disk if you clone VMs instead of templates. I only have problems getting "Compact" (thin-provisioned) disks.

Raoulst

0 Kudos
Expert
Expert

That sounds like a good work around.

0 Kudos
Contributor
Contributor

Unfortunately that doesn't always work. Sometimes cloning from a thin template to another thin one just results in a thick template, sometimes it doesn't.

Raoulst

0 Kudos
Contributor
Contributor

I have an open Support Request on this issue, and got a message yesterday, saying that this is a known bug in VC 2.0.1

Raoulst

0 Kudos