huxleyhs
Contributor
Contributor

Cannot start vCenter: 503 Service unavailable

Jump to solution

Hello!

 

I got this message above from web browser, while I try to connect to vCenter:

503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x000055816a6c0720] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)

 

And I have this image from shell that shows which services have started (attached)

 

 

There are like many solutions online, but I do not know where to start...I also found some articles that looks like with my problem, like certificate, but i dont know if is the same.

 

I appreciate your time trying to help me

 

Huxley

0 Kudos
25 Replies
Ajay1988
VMware Employee
VMware Employee

All services down. That's quite odd.

Can you just  run " service-control --start --all " and see what it is failing for ? Share screenshot ?
Then you might have to check the log for that particular service.

 

Also the following one-liner can determine expired certificates other than STS for the vCSA:
for i in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list); do echo STORE $i; sudo /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $i --text | egrep "Alias|Not After"; done

For STS cert expiry check : https://kb.vmware.com/s/article/79248

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
huxleyhs
Contributor
Contributor

Hello @Ajay1988 

Thank you for supporting me.

Follow the prints:

huxleyhs_0-1665781533981.png

huxleyhs_1-1665781589864.png

huxleyhs_4-1665781919391.png

 

 

According to vxpd-svcs.log the error is about LDAP, follow below the print from log.

huxleyhs_2-1665781803860.png

huxleyhs_3-1665781828962.png

There are several erros about LDAP.

Thank you!

0 Kudos
Ajay1988
VMware Employee
VMware Employee

The complete command is below 
for i in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list); do echo STORE $i; sudo /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $i --text | egrep "Alias|Not After"; done

 

Also this might be little complicated and better to contact support.

Check cm.log first. What version of VC is this and is it external PSC ? 

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
huxleyhs
Contributor
Contributor

Hi @Ajay1988 

The certifactes are valid.

huxleyhs_0-1665848224705.png

Follow attached CM.LOG.

The versions is: 6.5.0.41000 Build Number 20510539.

This VCenter is a VM inside an Esxi (physical host).

We dont have support active at VMWare.

We are thinking in re install the Vcenter.

 

Thank you!

0 Kudos
Ajay1988
VMware Employee
VMware Employee

cm.log says it is down from 2nd July 2022. I suppose it might be better to re-install VC. 

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
maksym007
Hot Shot
Hot Shot

yeah, good point

0 Kudos