ESXNewby
Enthusiast
Enthusiast

Cannot start VMWare VirtualCenter Server service - error 1067

Hi.

Our VC service has been running for about 2 months.

Today I made a change the license file loaded on the license server.

I restarted all the services, but now the VC Server service does not want to start:

Could not start the VMware VirtualCenter Server service on local computer.

Error 1067: The process terminated unexpectedly.

I tried to repair the VC but this did not make any different.

Any suggestions would be surely appreciated.

Thanks

Newby

0 Kudos
19 Replies
sbeaver
Leadership
Leadership

If you have SQL local make sure it is running. Make sure the license server service is running. Anything in the event logs?

Steve Beaver
VMware Communities User Moderator
VMware vExpert 2009 - 2020
VMware NSX vExpert - 2019 - 2020
====
Co-Author of "VMware ESX Essentials in the Virtual Data Center"
(ISBN:1420070274) from Auerbach
Come check out my blog: [www.virtualizationpractice.com/blog|http://www.virtualizationpractice.com/blog/]
Come follow me on twitter http://www.twitter.com/sbeaver

**The Cloud is a journey, not a project.**
0 Kudos
esiebert7625
Immortal
Immortal

Check your Event viewer for any errors, also check the VC logs in C:\Windows\Temp\VPX for a more detailed error.

0 Kudos
ESXNewby
Enthusiast
Enthusiast

SQL is running on another Server in the network.

License server is running locally.

Event log:

The description for Event ID ( 1000 ) in Source ( VMware VirtualCenter Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Starting VMware VirtualCenter 2.0.1 build-32042.

This is from the vpxd.log file, not sure if it would help.

Log for VMware VirtualCenter, pid=2572, version=2.0.1, build=build-32042, option=Release, section=2

\[2007-05-03 12:18:15.965 'App' 1484 info] Current working directory: C:\WINDOWS\system32

\[2007-05-03 12:18:15.965 'App' 1484 info] Initializing SSL context

\[2007-05-03 12:18:16.808 'App' 1484 info] Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

\[2007-05-03 12:18:16.808 'BaseLibs' 1484 info] NFC connection accept timeout: 180000 milliseconds

\[2007-05-03 12:18:16.808 'BaseLibs' 1484 info] NFC request timeout: 180000 milliseconds

\[2007-05-03 12:18:16.808 'BaseLibs' 1484 info] NFC read timeout: 60000 milliseconds

\[2007-05-03 12:18:16.808 'BaseLibs' 1484 info] NFC write timeout: 600000 milliseconds

\[2007-05-03 12:18:16.808 'App' 1484 info] Starting VMware VirtualCenter 2.0.1 build-32042

\[2007-05-03 12:18:16.808 'App' 1484 info] Account name: SYSTEM

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxOsLayer] Enabled low-frag process heap.

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxOsLayer] Enabled low-frag crt heap.

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 32 max LROs

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 6 reserved internal LROs

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 6 reserved blocker LROs

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 6 reserved short LROs

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 2 reserved long LROs

\[2007-05-03 12:18:16.808 'App' 1484 info] \[VpxLRO] 600-second task lifetime

\[2007-05-03 12:18:23.152 'Locale' 1484 info] Locale subsystem initialized from C:\Program Files\VMware\VMware VirtualCenter 2.0\locale/ with default locale en.

\[2007-05-03 12:18:23.262 'App' 1484 error] Found domain with invalid name . Removing /vpx/domain/#s78/

\[2007-05-03 12:18:23.262 'App' 1484 error] Found resource group with invalid name . Removing /vpx/resgroup/#80/

Thanks

0 Kudos
esiebert7625
Immortal
Immortal

Check out this post, this is almost always a database connection problem.

http://www.vmware.com/community/thread.jspa?messageID=581836

Also this one...

http://www.vmware.com/community/thread.jspa?messageID=478880&#478880

Message was edited by:

esiebert7625

ESXNewby
Enthusiast
Enthusiast

Not sure what is happening but this did not help.

What is tried is the following:

1. Checked the ODBC connection. (Successful and using SQL authentication)

2. Checked the "log on as" for service.

3. Checked that no locked processes are running on SQL database

4. Checked log file and and database size for VC database. both fine.

5. Checked using netstat -a for port still open. no problem.

6. IIS not installed

I could not find anything related to our error in the log file:

\[2007-05-03 13:37:15.511 'App' 3656 error] Found domain with invalid name . Removing /vpx/domain/#s78/

\[2007-05-03 13:37:15.511 'App' 3656 error] Found resource group with invalid name . Removing /vpx/resgroup/#80/

Where would the domain name and resource group be looked up?

Thanks

Johann

0 Kudos
esiebert7625
Immortal
Immortal

Probably in the SQL database, VC stores all of it's data there.

0 Kudos
ESXNewby
Enthusiast
Enthusiast

I went through VM Support, and the only way to resolve my issue was to uinstall VC server, delete the database and reinstall.

0 Kudos
esiebert7625
Immortal
Immortal

Thats a little extreme, deleting everything and starting over. I can't believe support would make you wipe out the database. Must of been a lazy tech that did not want to fix what was wrong with the app/database specifically and decided a re-install of everything was the answer.

0 Kudos
johnswb
Enthusiast
Enthusiast

I'm have the same problem. I'm looking on the forum before calling vm-support. I've thought about starting with a clean database but I really would like to keep all the data that has been created.

Will Johnson VCP on VI3 / VI4 vSphere 5
0 Kudos
OlivierTremolie
Enthusiast
Enthusiast

Hi all,

To initiate the database, the user you're using for SQL database must be Sys_admin. After the regeneration of the database, you can modify security options on SQL Server disable sys_admin rights.

Olivier

Olivier ############### If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!
0 Kudos
Sangokan
Enthusiast
Enthusiast

I had the sma eproblem recently and the fix was to disable IIS first because it was conflicting with VC. Might give it a try before reinstalling.

0 Kudos
OlivierTremolie
Enthusiast
Enthusiast

Hi,

Yes you're right. There is a conflic with IIS because VC need Tomcat Web Server. Like all web server, Tomcat is using 80 port. So there is a conflic with the port 80 (used for http). If you need to keep IIS for your web sites, you can modify the default port on IIS. For this, right clik on the default web site and choose another port number.

Olivier

Olivier ############### If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!
0 Kudos
VM_Explorer
Contributor
Contributor

THIS SOLVED MY PROBLEM. Check for this resolution.

Requirements for Running VirtualCenter with MS SQL 2005

|

VMware VirtualCenter

Details

|VMware has tested and certified Microsoft SQL Server 2005 SP1 for use with VirtualCenter Server 2.0.1. Important: This configuration requires the VirtualCenter Server database login to be the owner of the database. A login with the db_owner role is not sufficient.

Although Microsoft has introduced the "SQL Native Client" ODBC driver with SQL Server 2005, the only supported ODBC driver for use with VirtualCenter Server is the "SQL Server" driver.

|

Solution

If the VirtualCenter Server service installs but does not start and logs the following error, this is a symptom that the SQL Server 2005 SP1 database is not configured correctly:

Failed to init tableDef: Column VER_ID does not exist in table VPX_VERSION. Database version may be incompatible.

This condition can occur if VirtualCenter Server was installed using a database login mapped to a user other than dbo. When the VirtualCenter login is the owner of the database, the login automatically maps to the dbo user.

There are two ways to achieve the correct configuration:

  • Configure a fresh installation.

  • Repair a fresh installation that does not start.

To configure a fresh installation:

  1. Connect to your SQL Server 2005 server with SQL Server Management Studio.

  2. Create a database login (vclogin) for VirtualCenter Server to use.

  3. Create a new database (VCDB) and change the owner from <default> to vclogin.

  4. Observe that vclogin maps to the dbo database user for VCDB.

  5. Change the default database for vclogin from master to VCDB.

  6. Install VirtualCenter Server according to the product documentation.

To repair a fresh installation that does not start:

If the database has already been created and VirtualCenter Server has already been installed, it is possible to modify the owner of the database with a system stored procedure. In the steps below, substitute <vcuser> and <vclogin> with your appropriate account names.

  1. Connect to your SQL Server 2005 server with SQL Server Management Studio.

  2. Go to the db_owner schema properties and change the owner from <vcuser> to dbo.

  3. Delete the <vcuser> database user (not the <vclogin> database login that maps to it).

  4. Open a new query window for the VirtualCenter database.

  5. Execute this command:
    EXEC sp_changedbowner @loginame = '<vclogin>', @map = 'true'

  6. Start the VirtualCenter Server service.

Reference the VirtualCenter Server Release Notes at for details on supported databases and client driver versions. For information how to identify your SQL Server version and edition, reference the Microsoft Knowlege Base article 321185 at .

0 Kudos
jevel
Contributor
Contributor

Moved my default website to port 8080 and it solved it.

This is a quick and easy solution.

-KJ

0 Kudos
kegwell
Enthusiast
Enthusiast

PROBLEM SOLVED: I had the identical problems as described in the original post. I tried several of the suggestions in this thread without success. I found this article () and it fixed my problem within 1 minute. In a nutshell, the ODBC for VIrtualCenter was trying to connect to the wrong SQL server hostname. Changed it to the correct hostname and VritualCenter fired up.

0 Kudos
virtualbot
Contributor
Contributor

Thank you very much Sangokan. The solution saved my day!! VMware community is the best!

Virtualbot

0 Kudos
KTencer
Contributor
Contributor

In my case the problem was vRanger pro 4.0. Stop all vRanger Pro tasks and start VIC server task. It fixed my problem.

KT

0 Kudos
ralphowens
Contributor
Contributor

For me this problem was caused by the fact that the SQL account I was using for the ODBC connections from my VC server to my SQL server had a password policy applied to it. This cause the ODBC connections on the VC server to think the SQL account's password was expired and would not allow the ODBC connection to be established. Once I removed the password policy from that SQL account on the SQL server the virtualcenter service came right up without a problem

0 Kudos
ktsu10
Contributor
Contributor

I ran into the same problem, too. IIS use port 80. But, my server does not have IIS installed. I disable SQL Server Reporting Service. That took care of my problem.

ktsu

0 Kudos