aj800
Enthusiast
Enthusiast

Cannot add ESXi 6.7 hosts to cluster: A general system error occurred: Unable to push CA certificates and CRLs to host

Jump to solution

I completed upgrading our vCenter Server appliance to 6.7U3.  After running into a number of issues doing that, I've finally got everything back normal.  The goal was to add new host hardware we have, which we installed ESXi 6.7 on.  Since we were running VCSA 6.5, I upgraded that to be able to create a new cluster for the new hosts to be managed by the 6.7 VCSA.

I created the new cluster, enabled DRS, enabled HA, then enabled and set EVC to the highest on the list (Intel Merom).  We're using hosts with Intel Xeon Gold 6143 CPUs.  I followed the wizard for adding new hosts, it seemed to connect and identify them with no issues, but when I start the adding by clicking finish, it fails immediately with the following error message:

A general system error occurred: Unable to push CA certificates and CRLs to host <hostname/IP>

I've tried using both the FQDN and IP, but get the same error.  We have not fully licensed these installations yet and they have whatever the default certificate is when you first install ESXi, which we did a few weeks ago.  The vCenter server is using a valid certificate issued by our enterprise CA.  What am I missing?

1 Solution

Accepted Solutions
aj800
Enthusiast
Enthusiast

Joining new hosts failed with certificate issues - I was getting certificate issues when trying to join NEW hosts to a new host cluster in this datacenter in vSphere.  There is a vCenter setting (vCenter -> Configure -> Settings -> Advanced Settings -> vpxd.certmgmt.mode) with a default value of 'vmca', and VMware support had changed the value to 'thumbprint' which then allowed the new hosts to join the cluster using their default certificates (these were newly installed ESXi 6.7 hosts).  Once they were added successfully, this setting was changed back to its default 'vmca'.

View solution in original post

11 Replies
a_p_
Leadership
Leadership

I ran into this myself two weeks ago.

A solution/workaround is actually documented in the VMware vCenter Server 6.7 Update 3 Release Notes​, see "You might be unable to add a self-signed certificate to the ESXi trust store and fail to add an ESXi host to the vCenter Server system"

André

0 Kudos
aj800
Enthusiast
Enthusiast

Joining new hosts failed with certificate issues - I was getting certificate issues when trying to join NEW hosts to a new host cluster in this datacenter in vSphere.  There is a vCenter setting (vCenter -> Configure -> Settings -> Advanced Settings -> vpxd.certmgmt.mode) with a default value of 'vmca', and VMware support had changed the value to 'thumbprint' which then allowed the new hosts to join the cluster using their default certificates (these were newly installed ESXi 6.7 hosts).  Once they were added successfully, this setting was changed back to its default 'vmca'.

View solution in original post

manhh
Contributor
Contributor

It's worked,

Thanks

0 Kudos
aig
Enthusiast
Enthusiast

worked for me as well.

thanks

0 Kudos
QuestorZ
Contributor
Contributor

Was grinding on this, fixed my issue, thanks for sharing the fix!

0 Kudos
firsway
Contributor
Contributor

Appreciate this is an older post now, but I've just had this issue occur myself.

It turned out that the host system date/time was "catastrophically" out (years out)

By setting this correctly on the host and rebooting, then retrying the operation, all was fine!

rojobull
Contributor
Contributor

While changing to vpxd.certmgmt.mode to thumprint works, I still questioned why this was happening all of a sudden? In my case, it turns out the host time was the issue. Correcting the host time resolved it for me and allowed me to add the host without modifying certmgmt.mode setting.

vmwaresucksatre
Contributor
Contributor

Yes thanks for that.

I had set my NTP server and made sure the service was started. Still got this error. What it needed was after all that, a host system reboot. So rebooting the esx server allowed it to join with no other changes.

0 Kudos
Stormeagle2
Contributor
Contributor

Thanks, it's work for me too.

0 Kudos
JSR59
Contributor
Contributor

Worked for me, but why would it need changed back to 'vmca' is ther a security issue with it left at 'thumbprint'?

0 Kudos
Ajay1988
VMware Employee
VMware Employee

This is not right as thumbprint should only be   used for   5.5 versions.   If the mode   is already   changed to  vmca; this   means   u r still   at issue.   The   VC will  not manage the   host certs  here.   Try a   new certs from   VC  UI for  ESXi and u will be back to the same problem

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos