Highlighted
Enthusiast
Enthusiast

Alarm problem

I have a iscsi datastore that reports as over allocated. The alarm set to 100% for warning. But the actual size is not even near to be over allocated.

There is no option to reset to green but only to acknowledge.

Tried refresh and restrting vcenter service.

Any ideas?

> if you found this or any other answer useful please consider allocating points for helpful or correct answers <
0 Kudos
4 Replies
Highlighted
Enthusiast
Enthusiast

A couple of things to check:

Is it possible that there are leftover files on the datastore for VMs that don't reside there anymore, such as old .vmdks taking up space?  You can open up the Browse Datastore browser and compare what you see listed against what is actually running and living on this datastore.

Maybe there is another overallocation alarm being applied from a different level in the vCenter tree?  I've seen this in the past, especially after upgrades to vCenter Server.  Having a default overallocation under 100% would be odd though...

Good luck

0 Kudos
Highlighted
Virtuoso
Virtuoso

Sometimes an alarm will get stuck, I especially have found this issue with storage alarms (such as datastore usage). I have found that this trick works:

  1. Go to the alarm definition, usually at the vCenter level.
  2. Edit the alarm.
  3. Change nothing and click OK.

See if that clears it up.

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
0 Kudos
Highlighted
Contributor
Contributor

Thanks for the trick, i had the same alarm problem (storage alert) and editing the alarm worked Smiley Happy

0 Kudos
Highlighted
Virtuoso
Virtuoso

I've found that this is fixed in vCenter 4.1u1 (at least it is for me).

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
0 Kudos