MillardJK
Enthusiast
Enthusiast

After 5.1.0a upgrade, Web Client "Use Windows session auth" fails

I don't know if anyone else has seen this, but after upgrading from 5.1.0 GA to 5.1.0a, I can no longer use Windows pass-thru authentication in the web client. It still works fine in the C# client (aka VIC), and the domain credentials work fine when manually entering them. It's only when the Web Client passthru is used.

This all worked prior to the upgrade.

I've gone through and changed service credentials from "Local System" to a domain service account, but that hasn't had any impact. Reinstalling the clipi (aka Client Integration Plug-In) didn't help either. The workaround, of course, is to ignore the passthru, but I thought I'd bring this to everyone's attention.

I'm going to see if I can replicate this in another environment, too.

——
Jim Millard
Kansas City, MO USA
0 Kudos
5 Replies
Zarra
Contributor
Contributor

Hi,

I have the same problem, do you solved it?

0 Kudos
MillardJK
Enthusiast
Enthusiast

In the process of attempting to move the databases from the vCenter/express instance to a standard SQL instance on a different host, I completely hosed the SSO setup. In order to fix that, I ended up uninstalling everything and reinstalling from scratch. I was unable to reuse the RSA database from the original SSO setup, and the complete reset seems to have fixed my problem: I am now able to use pass-through.

as an aside, there was no problem with the vCenter database, so the reinstall was not as bad as it could've been.

——
Jim Millard
Kansas City, MO USA
0 Kudos
criver
Enthusiast
Enthusiast

Hi,

I've had the same "Problem", in Japanese Environment.

In this case, do we have no choice but to uninstall everything and to reinstall from scratch ?

0 Kudos
MillardJK
Enthusiast
Enthusiast

You can open a case with support and see if they can dial in to a root cause and solution. It wasn't a big enough problem--just an annoyance, really--to merit putting any effort into it. The j# client still worked, and unless you needed a 5.1-specific feature, that was good enough.

——
Jim Millard
Kansas City, MO USA
0 Kudos
criver
Enthusiast
Enthusiast

Thank you for your feedback.

You mean this issue is a drop in the ocean ?

So, I don't apply this patch vCS5.1a,

I think  I'll wait for the next Patch.

0 Kudos