jleyton
Contributor
Contributor

Adding extent issue post VC4.1 upgrade

Wondering if anybody has any guidance on this issue.

Since upgrading to VC4.1, we're having problems adding an extent to an existing datastore.  We were allocated 2 new luns which all nodes of the cluster can see and confirmed this via the storage adapters pane.  If I go to create a new datastore, I can use these two luns and the process goes through without a hitch.  If I try to use either of these luns to add an extent to a pre-existing datastore, no luns show up as available.

Additionally to make sure theres nothing wrong with the datastore itself, I pointed my vsphere client directly to each ESX servers rather than vCenter.  Went through the motion of trying to add and extent and the luns show up no problem on every node of the cluster.  This to me confirms that the luns are accessible by all servers and can be added to the existing datastore according to each node.  I'm afraid to add the luns to the datastore this way for any data corruption that might happen with the extent not being added through vcenter.  This leads me to believe something is wrong with vCenter4.1 or something wrong in my SQL2005 database.

Any thoughts are greatly appreciated.

0 Kudos
1 Reply
AndreTheGiant
Immortal
Immortal

Do you have mixed hosts with 4.x and 3.x version?

Otherwise if you have same kind of host (4.x) do not use extent and simple extend your LUN and then increase the VMFS datastore.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos