lil328i
Enthusiast
Enthusiast

Adding a secondary network interface to Ubuntu JEOS in ESXi

Jump to solution

Hi everyone,

I was able to migrate a Ubuntu JEOS 32bit http server and get eth0 working : - ) Thank You!

I'm now trying to add a secondary NIC to that server. I have ESXi set up with 2 nics in each subnet. I added another virtual ethernet adapter to the VM.

Problem is, ESXi is assigning the MAC address from my primary nic, and wont assign the mac for the secondary nic?

Am i doing something wrong?

Peter

Thanks & Regards Peter K. VCP 5.1
0 Kudos
1 Solution

Accepted Solutions
puzzledtux
Hot Shot
Hot Shot

I am not sure if that option is present in your distribution of linux. In CentOS, RHEL etc..there is a option present in the network configuration page (run neat cmd from the GUI), wherein it allows you to probe the mac address assigned to the NIC automatically.

I don't think you would actually require to probe the mac address. But just in case if any suggestions don't work you can delete the second NIC from the virtual machine, remove all the settings for the NIC card in your GOS network files. Add a fresh new NIC card and configure the settings again!

View solution in original post

0 Kudos
12 Replies
Chamon
Commander
Commander

So you have 2 vNICs for your Vm one on each subnet. Do you have one vSwitch and multiple subnet's? And both of your NICs has the same MAC address? You didn't create and eth0:1 correct. The VM sees them as two NICs. eth0 and eth1? Just making sure I understand what you have.

0 Kudos
lil328i
Enthusiast
Enthusiast

Yes, I have two hard wired nics, two for each subnet, teamed in ESXi.

I have one vswitch for one subnet, which works fine.

I have another vswitch for the other subnet.

In esxi, the Ubuntu http servers shows up as "green" in the networking config menu.

my prinary working nic looks like this:

  1. The primary network interface

auto eth0

iface eth0 inet static

address 192.168.3.90

gateway 192.168.3.1

netmask 255.255.255.0

network 192.168.3.0

broadcast 192.168.3.255

my secon nic in ubuntu vm that does NOT work looks like this:

auto eth0:1

iface eth0:1 inet static

address 192.168.1.60

netmask 255.255.255.0

network 192.168.1.0

broadcast 192.168.1.255

gateway 192.168.1.1

when I run ifconfig, I get the correct ip address assignments, but, I also get the same MAC address assigned to both nics.

I will try to upload a screen shot from my vmware console :

Peter

Thanks & Regards Peter K. VCP 5.1
0 Kudos
Chamon
Commander
Commander

You need to add another vNIC in the edit setting of the VM then it will have its own MAC address. You have created a virtual NIC in the os but need to create it at the VM level instead. Make sence?

Right click the VM and then choose edit settings then hit the add button and add a second NIC here.

Message was edited by: Chamon

0 Kudos
lil328i
Enthusiast
Enthusiast

same result, assigns the same mac address to eth0:1 as I have assigned to eth0:0

ugh: (

Thanks & Regards Peter K. VCP 5.1
0 Kudos
Chamon
Commander
Commander

Were there any options when you created the second NIC? It is strange that you are getting the second one with the same MAC. There is always the option to manualy chang it on the edit settings window but I wouldn't want to do that. Can you remove the secon vNIC and add it back again? Or add a third and see what the MAC address is?

0 Kudos
Chamon
Commander
Commander

Does the MAC in the OS reflect what you see in the ESXi host?

Shouldn't your second vNIC be eth1 instead of eth0:1? Isnt that a virtual NIC in the OS that would share the same piece of hardware For a new or second NIC it should be eth1. So I am a little confused. What did you do in the os after you added the second vNIC in ESX?

lil328i
Enthusiast
Enthusiast

I will try your suggestions Monday, were closing down shop and I'll get kicked out in a bit : )

Peter

Thanks & Regards Peter K. VCP 5.1
0 Kudos
puzzledtux
Hot Shot
Hot Shot

I think there should be separate interfaces in your guest operating system. The first NIC should be assigned eth0 (this seems to be correct) but the second NIC should not be eth0:1, instead it should be eth1.

I think you only need to put eth1 in proper place in your config file and restat the network. Also there should be an option the GOS to probe the hardware address for the connected NIC.

lil328i
Enthusiast
Enthusiast

I think you are right, I made eth1 an alias to eth0 in my haste, which accounts for why it's using the same mac address.

I will try your suggestion Monday.

Can you explain what you mean by >Also there should be an option the GOS to probe the hardware address

Thanks!

Peter

Thanks & Regards Peter K. VCP 5.1
0 Kudos
puzzledtux
Hot Shot
Hot Shot

I am not sure if that option is present in your distribution of linux. In CentOS, RHEL etc..there is a option present in the network configuration page (run neat cmd from the GUI), wherein it allows you to probe the mac address assigned to the NIC automatically.

I don't think you would actually require to probe the mac address. But just in case if any suggestions don't work you can delete the second NIC from the virtual machine, remove all the settings for the NIC card in your GOS network files. Add a fresh new NIC card and configure the settings again!

0 Kudos
lil328i
Enthusiast
Enthusiast

This isssue is resolved. The problem was the secondary interface in Ubuntu should have been eth1 and NOT eth0:1

Thanks all Smiley Wink

Peter

Thanks & Regards Peter K. VCP 5.1
0 Kudos
Chamon
Commander
Commander

Good to hear you got it worked out.

On Jun 1, 2009, at 6:52 PM, lil328i <communities-emailer@vmware.com

0 Kudos