jamesreinke2
Enthusiast
Enthusiast

Add permission fails with error

We have a newer 6.5 vcenter that I am trying to add a particular user to a particular VM for management but the following error message occurs

The "Add permission" operation failed for the entity with the following error message.

Provider method implementation threw unexpected exception: %s

All vCenters are 6.5 U3. However two of them this works on have been upgraded from 5.5. Has this type of permission setting been deprecated. If so is their a workaround? Otherwise I'm at a loss. Even setting the permissions from the top down gives me the same error. The only way I can set the permissions is from the "Global Permissions" but I do not want them to even see anything other than what they are allowed

Following articles still give me the same error

Assign a User Permissions for a Virtual Machine in the VMware Host Client

Understanding the vCenter Server Permission Model

0 Kudos
2 Replies
NathanosBlightc
Commander
Commander

I think this situation will happen when you try to upgrade from windows-based vCenter to the appliance-based.

Please look at the following link. It's exactly same as your problem, and the solution seems to be reliable:

https://www.techcrumble.net/2018/03/lost-permissions-after-the-vsphere-6-5-vcsa-migration-from-windo...

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
RickVerstegen
Expert
Expert

Ar you giving that particular user direct access? Try to use a group with the user as a member and try again setting permission.

Does the account have a space in their user ID?

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos