jrv116
Contributor
Contributor

vhost availabilty is 0% .. vhost reporting it is down when it is not.

I have two servers behind a load balancer that host a website. the hq agent installed correctly and it autodiscovered but the vhosts that showup as the website both report they are down?

why would this be and what should I check on / how does hyperic determine that the site is down?

the site clearly isnt down and is clearly available.. I can browse to it... both on and off the server.. I even pointed the load balancer to each node and hit the site externally both directly (no load balancer) and indirectly (with load balancer) and it is definitely up.

any recommendations ?
0 Kudos
8 Replies
excowboy
Virtuoso
Virtuoso

Hi,

Hyperic HQ evalutes the Host Header Name to determine if a Vhost is available. Look for this option in Hyperic HQ:
Server IIS -> Vhost -> Inventory -> Configuration Properties
Please specify the Host Header Name according to your IIS configuration, save the configuration and be patient some minutes until your Vhost recovers

hope this helps
Mirko
0 Kudos
jrv116
Contributor
Contributor

That did not seem to correct the issue. I have checked in IIS and none of the sites have host header values because each site is on a separate IP making it unnecessary. Perhaps we could describe in more detail how the availability is determined. it is from the server running the agent or from the hyperic server?

the server I am monitoring is dual-homed and the ip address associated with the website is on the farside of the server which is not visible/pingable from the hyperic-hq server.

however this is not an issue if the agent is monitoring availability since the agent is on the server with both nics so it can see both sides.

what else could cause this?
0 Kudos
xmanx
Contributor
Contributor

I have exactly the same problem.
I am running Hyperic agent version 3.2.3.659 on a Windows Server 2003 R2 SP2.
My IIS 6 server has 12 websites in the same application pool. 5 of these have availability of 0% even if they are up and running. All other parameters (Bytes Received / sent per minute, etc) working correctly. It is the measurement of the availability that do not work as intended.

I have checked and compared all the web site settings. I have also checked the security rights to the document root and log directory. To me it seems that everything is correct.

I hope someone has good suggestions for the solution to this problem so that I can continue to use this excellent tool.
0 Kudos
excowboy
Virtuoso
Virtuoso

Hi,

I don't have IIS, but I had a look at the plugin source. This is an except from it:

This is the part defining availability:

<metrics name="vhost-avail">
<metric name="Availability"
alias="Availability"
template="%protocol%:${url.config},hostheader=%hostheader%:${alias}"
category="AVAILABILITY"
group="Reliability"
indicator="true"
collectionType="dynamic"
units="percentage"/>
</metrics>

This is the most important line, defining how to query the availability

template="%protocol%:${url.config},hostheader=%hostheader%:${alias}"

protocol, and hostheader are full configurable:

<config type="measurement" include="protocol,url">
<option name="hostheader"
description="Host Header Name"/>


So what you can do (and already did) is check the parameters and examine the agent.log.
Please increase HQ Agent loglevel. Edit agent.properties and set

agent.logLevel=DEBUG

and restart your agent. Then search agent.log for entries like this:

./hyperic-hq-agent-3.2.0/log/agent.log:2008-02-27 21:45:00,325 DEBUG [ScheduleThread] [2:10038:AVAILABILITY] Metric='JBoss 4.0:jboss.system:service=MainDeployer:StateString:java.naming.provider.url=jnp%3A//127.0.0.1%3A2099,java.naming.security.principal=%java.naming.security.principal%,java.naming.security.credentials=%java.naming.security.credentials%' -> 1 timestamp=1204145100325


Of course you have to look for IIS specific entries, but the line also contains strings like AVAILABILITY. In the example above the availability check returns "-> 1", which means available, "-> 0" is not available.
If you find such entries please post them here.

Many thanks !
Mirko
0 Kudos
xmanx
Contributor
Contributor

This is what I found in the log. It is consistent with what I see in the web interface of Hyperic. I have only included info for two websites

2008-06-18 08:15:00,343 DEBUG [ScheduleThread] [ScheduleThread] [3:10319:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=80,sotimeout=10,path=/,hostheader=sitea.example.com:Availability' -> 1 timestamp=1213769700343
2008-06-18 08:15:00,343 DEBUG [ScheduleThread] [ScheduleThread] [3:10318:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=80,sotimeout=10,path=/,hostheader=siteb.example.com:Availability' -> 0 timestamp=1213769700343


I see in the log that there are four exceptions that repeat itself. All of these are .NET error messages. Is there anything special I have to check with ASP.NET?

2008-06-18 08:20:00,312 ERROR [ScheduleThread] [ScheduleThread] Metric Value not found while processing Metric '.NET 2.0 Application:.NET CLR Memory(w3wp):Platform=Win32:# Bytes in all Heaps'
org.hyperic.hq.product.MetricNotFoundException: \.NET CLR Memory(w3wp)\# Bytes in all Heaps
at org.hyperic.hq.product.Win32MeasurementPlugin.getPdhValue(Win32MeasurementPlugin.java:211)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValueCompat(Win32MeasurementPlugin.java:138)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValue(Win32MeasurementPlugin.java:52)
at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:274)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:322)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.run(ScheduleThread.java:473)
at java.lang.Thread.run(Unknown Source)

2008-06-18 08:20:00,312 ERROR [ScheduleThread] [ScheduleThread] Metric Value not found while processing Metric '.NET 2.0 Application:.NET CLR LocksAndThreads(w3wp):Platform=Win32:# of current physical Threads'
org.hyperic.hq.product.MetricNotFoundException: \.NET CLR LocksAndThreads(w3wp)\# of current physical Threads
at org.hyperic.hq.product.Win32MeasurementPlugin.getPdhValue(Win32MeasurementPlugin.java:211)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValueCompat(Win32MeasurementPlugin.java:138)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValue(Win32MeasurementPlugin.java:52)
at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:274)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:322)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.run(ScheduleThread.java:473)
at java.lang.Thread.run(Unknown Source)

2008-06-18 08:20:00,328 ERROR [ScheduleThread] [ScheduleThread] Metric Value not found while processing Metric '.NET 2.0 Application:.NET CLR Exceptions(w3wp):Platform=Win32:# of Exceps Thrown__RATE__=1m'
org.hyperic.hq.product.MetricNotFoundException: \.NET CLR Exceptions(w3wp)\# of Exceps Thrown
at org.hyperic.hq.product.Win32MeasurementPlugin.getPdhValue(Win32MeasurementPlugin.java:211)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValueCompat(Win32MeasurementPlugin.java:138)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValue(Win32MeasurementPlugin.java:52)
at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:228)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:322)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.run(ScheduleThread.java:473)
at java.lang.Thread.run(Unknown Source)

2008-06-18 08:20:00,359 ERROR [ScheduleThread] [ScheduleThread] Metric Value not found while processing Metric '.NET 2.0 Application:.NET CLR Loading(w3wp):Type=Availability:Total Assemblies'
org.hyperic.hq.product.MetricNotFoundException: \.NET CLR Loading(w3wp)\Total Assemblies
at org.hyperic.hq.product.Win32MeasurementPlugin.getPdhValue(Win32MeasurementPlugin.java:211)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValueCompat(Win32MeasurementPlugin.java:138)
at org.hyperic.hq.product.Win32MeasurementPlugin.getValue(Win32MeasurementPlugin.java:52)
at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:274)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:322)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.run(ScheduleThread.java:473)
at java.lang.Thread.run(Unknown Source)
0 Kudos
excowboy
Virtuoso
Virtuoso

Hi,

could you please post some more logfile before and after the entries ?

2008-06-18 08:15:00,343 DEBUG [ScheduleThread] [ScheduleThread] [3:10319:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=80,sotimeout=10,path=/,hostheader=sitea.example.com:Availability' -> 1 timestamp=1213769700343
2008-06-18 08:15:00,343 DEBUG [ScheduleThread] [ScheduleThread] [3:10318:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=80,sotimeout=10,path=/,hostheader=siteb.example.com:Availability' -> 0 timestamp=1213769700343

Mirko
0 Kudos
jrv116
Contributor
Contributor

Here's a chunk of my log...

one interesting thing I noticed was it got a 403 for http://10.100.28.104:80 but if I put 10.100.28.104:80 in on my server I get our main page... odd...

See anything out of the ordinary here??



2008-07-29 16:21:22,530 ERROR [SenderThread] [SenderThread] Agent is 425 seconds behind the server. To ensure accuracy of the charting and alerting make sure the agent and server clocks are syncronized
2008-07-29 16:21:25,155 DEBUG [CollectorThread] [Collector] Running http collectors
2008-07-29 16:21:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, hostheader=reports.gigatrust.net, sotimeout=10, path=/} ran 49 seconds ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:21:25,155 DEBUG [CollectorThread] [Collector] {port=5720, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 59 seconds ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:21:25,155 DEBUG [CollectorThread] [CollectorThread] CompletedTaskCount=2, ActiveCount=3, TaskCount=5, PoolSize=6
2008-07-29 16:21:25,155 DEBUG [pool-1-thread-4] [Collector] name=http, thread=pool-1-thread-4, result=Tue Jul 29 16:21:25 EDT 2008 [Debug] (http://10.100.28.106:80/) 302 Object Moved values={StateTIME_WAIT=3.0, AllOutboundConnections=7.0, StateLAST_ACK=0.0, StateCLOSE_WAIT=1.0, StateESTABLISHED=6.0, AllInboundConnections=4.0, InboundConnections=1.0, ResponseTime=0.0, StateFIN_WAIT2=1.0, ResponseCode=302.0, OutboundConnections=1.0, Availability=1.0, StateBOUND=0.0, StateFIN_WAIT1=0.0, StateLISTEN=0.0, StateSYN_SENT=0.0, StateCLOSING=0.0, StateCLOSE=0.0, StateIDLE=0.0, StateSYN_RECV=0.0, StateUNKNOWN=0.0}
2008-07-29 16:21:25,155 DEBUG [pool-1-thread-5] [Collector] name=http, thread=pool-1-thread-5, result=Tue Jul 29 16:21:25 EDT 2008 [Debug] (http://10.100.28.102:80/) 401 Unauthorized (Microsoft-IIS/6.0) values={StateTIME_WAIT=3.0, AllOutboundConnections=7.0, StateLAST_ACK=0.0, StateCLOSE_WAIT=1.0, StateESTABLISHED=6.0, AllInboundConnections=4.0, InboundConnections=1.0, ResponseTime=0.0, StateFIN_WAIT2=1.0, ResponseCode=401.0, OutboundConnections=2.0, Availability=1.0, StateBOUND=0.0, StateFIN_WAIT1=0.0, StateLISTEN=0.0, StateSYN_SENT=0.0, StateCLOSING=0.0, StateCLOSE=0.0, StateIDLE=0.0, StateSYN_RECV=0.0, StateUNKNOWN=0.0}
2008-07-29 16:21:25,155 DEBUG [pool-1-thread-6] [Collector] name=http, thread=pool-1-thread-6, result=Tue Jul 29 16:21:25 EDT 2008 [Debug] (http://localhost:80/) 401 Unauthorized (Microsoft-IIS/6.0) values={StateTIME_WAIT=3.0, AllOutboundConnections=7.0, StateLAST_ACK=0.0, StateCLOSE_WAIT=1.0, StateESTABLISHED=6.0, AllInboundConnections=4.0, InboundConnections=1.0, ResponseTime=0.0, StateFIN_WAIT2=1.0, ResponseCode=401.0, OutboundConnections=2.0, Availability=1.0, StateBOUND=0.0, StateFIN_WAIT1=0.0, StateLISTEN=0.0, StateSYN_SENT=0.0, StateCLOSING=0.0, StateCLOSE=0.0, StateIDLE=0.0, StateSYN_RECV=0.0, StateUNKNOWN=0.0}
2008-07-29 16:21:25,170 DEBUG [pool-1-thread-3] [Collector] name=http, thread=pool-1-thread-3, result=Tue Jul 29 16:21:25 EDT 2008 [Error] (http://10.100.28.104:80/) 403 Forbidden (Microsoft-IIS/6.0) values={StateTIME_WAIT=3.0, AllOutboundConnections=7.0, StateLAST_ACK=0.0, StateCLOSE_WAIT=1.0, StateESTABLISHED=6.0, AllInboundConnections=4.0, InboundConnections=1.0, ResponseTime=15.0, StateFIN_WAIT2=1.0, ResponseCode=403.0, OutboundConnections=2.0, Availability=0.0, StateBOUND=0.0, StateFIN_WAIT1=0.0, StateLISTEN=0.0, StateSYN_SENT=0.0, StateCLOSING=0.0, StateCLOSE=0.0, StateIDLE=0.0, StateSYN_RECV=0.0, StateUNKNOWN=0.0}
2008-07-29 16:22:00,014 DEBUG [AvailScheduleThread] [ScheduleThread] [1:10205:AVAILABILITY] Metric='Win32:system.avail:Type=Platform:Availability' -> 1 timestamp=1217362920014
2008-07-29 16:22:22,561 ERROR [SenderThread] [SenderThread] Agent is 425 seconds behind the server. To ensure accuracy of the charting and alerting make sure the agent and server clocks are syncronized
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] Running http collectors
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.104, ssl=false, sotimeout=10, path=/} ran 59 seconds ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, hostheader=reports.gigatrust.net, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=5720, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.102, ssl=false, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:22:25,155 DEBUG [CollectorThread] [CollectorThread] CompletedTaskCount=6, ActiveCount=0, TaskCount=6, PoolSize=6
2008-07-29 16:23:00,014 DEBUG [AvailScheduleThread] [ScheduleThread] [1:10205:AVAILABILITY] Metric='Win32:system.avail:Type=Platform:Availability' -> 1 timestamp=1217362980014
2008-07-29 16:23:23,155 ERROR [SenderThread] [SenderThread] Agent is 425 seconds behind the server. To ensure accuracy of the charting and alerting make sure the agent and server clocks are syncronized
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] Running http collectors
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.104, ssl=false, sotimeout=10, path=/} ran 1 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, hostheader=reports.gigatrust.net, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=5720, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.102, ssl=false, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:23:25,155 DEBUG [CollectorThread] [CollectorThread] CompletedTaskCount=6, ActiveCount=0, TaskCount=6, PoolSize=6
2008-07-29 16:24:00,014 DEBUG [AvailScheduleThread] [ScheduleThread] [1:10205:AVAILABILITY] Metric='Win32:system.avail:Type=Platform:Availability' -> 1 timestamp=1217363040014
2008-07-29 16:24:24,311 ERROR [SenderThread] [SenderThread] Agent is 425 seconds behind the server. To ensure accuracy of the charting and alerting make sure the agent and server clocks are syncronized
2008-07-29 16:24:25,155 DEBUG [CollectorThread] [Collector] Running http collectors
2008-07-29 16:24:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.104, ssl=false, sotimeout=10, path=/} ran 2 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, sotimeout=10, path=/} ran 3 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,155 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, hostheader=reports.gigatrust.net, sotimeout=10, path=/} ran 3 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,217 DEBUG [CollectorThread] [Collector] {port=5720, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 4 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.102, ssl=false, sotimeout=10, path=/} ran 3 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 3 minutes ago, consumed n/a, 10min itv: deferring.
2008-07-29 16:24:25,217 DEBUG [CollectorThread] [CollectorThread] CompletedTaskCount=6, ActiveCount=0, TaskCount=6, PoolSize=6
2008-07-29 16:25:00,014 DEBUG [AvailScheduleThread] [ScheduleThread] [1:10205:AVAILABILITY] Metric='Win32:system.avail:Type=Platform:Availability' -> 1 timestamp=1217363100014
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] Retrying 6 items (MetricValue.FUTUREs)
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=19701|dsnId=19700]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=19537|dsnId=19536]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=19373|dsnId=19372]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=20029|dsnId=20028]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=19209|dsnId=19208]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] retrying -> [derivedId=19865|dsnId=19864]
2008-07-29 16:25:00,014 DEBUG [ScheduleThread] [ScheduleThread] [3:10232:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=D%3A\:Free' -> 21,107,004 timestamp=1217363100014
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [3:10241:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(reports)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [3:10244:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(www.com)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [3:10240:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(Dummy)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [2:10225:PERFORMANCE] Metric='HQ Agent:camAgent:Monitor=camMetric.sender:ServerOffset' -> 425,856 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [2:10225:UTILIZATION] Metric='HQ Agent:camAgent:Monitor=agent:JVMFreeMemory' -> 3,011,712 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [1:10205:UTILIZATION] Metric='Win32:sigar:Type=CpuPerc:Combined' -> 0.097 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [3:10238:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=1:User' -> 0.056 timestamp=1217363100280
2008-07-29 16:25:00,280 DEBUG [ScheduleThread] [ScheduleThread] [3:10237:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=0:Combined' -> 0.071 timestamp=1217363100280
2008-07-29 16:25:00,295 DEBUG [ScheduleThread] [ScheduleThread] [3:10246:UTILIZATION] Metric='.NET 1.1 Application:.NET CLR LocksAndThreads(LoggingComponen):Platform=Win32:# of current physical Threads' -> 1 timestamp=1217363100295
2008-07-29 16:25:00,295 DEBUG [ScheduleThread] [ScheduleThread] [3:10243:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(www.net)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100295
2008-07-29 16:25:00,295 DEBUG [ScheduleThread] [ScheduleThread] [3:10238:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=1:Combined' -> 0.125 timestamp=1217363100295
2008-07-29 16:25:00,295 DEBUG [ScheduleThread] [ScheduleThread] [3:10237:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=0:User' -> 0.031 timestamp=1217363100295
2008-07-29 16:25:00,295 DEBUG [ScheduleThread] [ScheduleThread] [3:10238:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=1:Idle' -> 0.875 timestamp=1217363100295
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [2:10224:UTILIZATION] Metric='IIS 6.x:\Web Service(_Total)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [3:10242:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(Windows RMS Administration Site)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [3:10237:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=0:Idle' -> 0.929 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [3:10245:UTILIZATION] Metric='.NET 1.1 Application:.NET CLR Memory(w3wp):Platform=Win32:# Bytes in all Heaps' -> 93,904,716 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [3:10237:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=0:Sys' -> 0.04 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [2:10224:AVAILABILITY] Metric='IIS 6.x:ServiceAvail:Platform=Win32:W3SVC' -> 1 timestamp=1217363100311
2008-07-29 16:25:00,311 DEBUG [ScheduleThread] [ScheduleThread] [3:10238:UTILIZATION] Metric='CPU:sigar:Type=CpuPercList,Arg=1:Sys' -> 0.069 timestamp=1217363100311
2008-07-29 16:25:00,327 DEBUG [ScheduleThread] [ScheduleThread] [3:10233:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=F%3A\:Free' -> 426,831,200 timestamp=1217363100327
2008-07-29 16:25:00,327 DEBUG [ScheduleThread] [ScheduleThread] [3:10246:UTILIZATION] Metric='.NET 1.1 Application:.NET CLR Memory(LoggingComponen):Platform=Win32:# Bytes in all Heaps' -> 4,926,468 timestamp=1217363100327
2008-07-29 16:25:00,342 DEBUG [ScheduleThread] [ScheduleThread] [2:10226:AVAILABILITY] Metric='.NET 1.1:.NET CLR Loading(_Global_):Type=Availability:Total Assemblies' -> 1 timestamp=1217363100342
2008-07-29 16:25:00,342 DEBUG [ScheduleThread] [ScheduleThread] [3:10233:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=F%3A\:UsePercent' -> 0.13 timestamp=1217363100342
2008-07-29 16:25:00,342 DEBUG [ScheduleThread] [ScheduleThread] [2:10225:AVAILABILITY] Metric='HQ Agent:camAgent:availability' -> 1 timestamp=1217363100342
2008-07-29 16:25:00,342 DEBUG [ScheduleThread] [ScheduleThread] [1:10205:UTILIZATION] Metric='Win32:sigar:Type=Swap:Used' -> 631,177,216 timestamp=1217363100342
2008-07-29 16:25:00,342 DEBUG [ScheduleThread] [ScheduleThread] [3:10245:UTILIZATION] Metric='.NET 1.1 Application:.NET CLR LocksAndThreads(w3wp):Platform=Win32:# of current physical Threads' -> 1 timestamp=1217363100342
2008-07-29 16:25:00,358 DEBUG [ScheduleThread] [ScheduleThread] [3:10231:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=C%3A\:UsePercent' -> 0.92 timestamp=1217363100358
2008-07-29 16:25:00,358 DEBUG [ScheduleThread] [ScheduleThread] [3:10231:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=C%3A\:Free' -> 865,004 timestamp=1217363100358
2008-07-29 16:25:00,358 DEBUG [ScheduleThread] [ScheduleThread] [3:10232:UTILIZATION] Metric='FileServer Mount:sigar:Type=MountedFileSystemUsage,Arg=D%3A\:UsePercent' -> 0.17 timestamp=1217363100358
2008-07-29 16:25:00,358 DEBUG [ScheduleThread] [ScheduleThread] [2:10226:UTILIZATION] Metric='.NET 1.1:.NET CLR Memory(_Global_):Platform=Win32:# Bytes in all Heaps' -> 19,729,452 timestamp=1217363100358
2008-07-29 16:25:00,373 DEBUG [ScheduleThread] [ScheduleThread] [2:10224:PERFORMANCE] Metric='IIS 6.x:\Active Server Pages\:Platform=Win32:Request Execution Time' -> 0 timestamp=1217363100373
2008-07-29 16:25:00,373 DEBUG [ScheduleThread] [ScheduleThread] [2:10226:UTILIZATION] Metric='.NET 1.1:.NET CLR LocksAndThreads(_Global_):Platform=Win32:# of current physical Threads' -> 913 timestamp=1217363100373
2008-07-29 16:25:00,373 DEBUG [ScheduleThread] [ScheduleThread] [1:10205:UTILIZATION] Metric='Win32:sigar:Type=Mem:Free' -> 1,300,078,592 timestamp=1217363100373
2008-07-29 16:25:00,373 DEBUG [ScheduleThread] [ScheduleThread] [3:10239:UTILIZATION] Metric='IIS 6.x VHost:\Web Service(RMS)\:Platform=Win32:Current Connections' -> 0 timestamp=1217363100373
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [2:10225:UTILIZATION] Metric='HQ Agent:camAgent:Monitor=agent:JVMTotalMemory' -> 7,794,688 timestamp=1217363100373
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10242:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=5720,sotimeout=10,path=/,hostheader=%hostheader%:Availability' -> 1 timestamp=1217363100389
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10241:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=10.100.28.106,port=80,sotimeout=10,path=/,hostheader=reports.gigatrust.net:Availability' -> 0 timestamp=1217363100389
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10240:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=localhost,port=80,sotimeout=10,path=/,hostheader=%hostheader%:Availability' -> 1 timestamp=1217363100389
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10244:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=10.100.28.104,port=80,sotimeout=10,path=/,hostheader=%hostheader%:Availability' -> 0 timestamp=1217363100389
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10239:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=10.100.28.102,port=80,sotimeout=10,path=/,hostheader=%hostheader%:Availability' -> 1 timestamp=1217363100389
2008-07-29 16:25:00,389 DEBUG [ScheduleThread] [ScheduleThread] [3:10243:AVAILABILITY] Metric='IIS 6.x VHost:http:ssl=false,hostname=10.100.28.106,port=80,sotimeout=10,path=/,hostheader=%hostheader%:Availability' -> 1 timestamp=1217363100389
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] Running http collectors
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.104, ssl=false, sotimeout=10, path=/} ran 4 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, sotimeout=10, path=/} ran 4 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.106, ssl=false, hostheader=reports.gigatrust.net, sotimeout=10, path=/} ran 4 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=5720, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 5 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=10.100.28.102, ssl=false, sotimeout=10, path=/} ran 4 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [Collector] {port=80, hostname=localhost, ssl=false, sotimeout=10, path=/} ran 4 minutes ago, consumed 24 seconds ago, 10min itv: deferring.
2008-07-29 16:25:25,217 DEBUG [CollectorThread] [CollectorThread] CompletedTaskCount=6, ActiveCount=0, TaskCount=6, PoolSize=6
2008-07-29 16:25:25,577 ERROR [SenderThread] [SenderThread] Agent is 425 seconds behind the server. To ensure accuracy of the charting and alerting make sure the agent and server clocks are syncronized
0 Kudos
jrv116
Contributor
Contributor

I also noticed that system has sufficent rights to the folder where .104 is stored.. it shouldnt be getting a 403....

any thoughts? hyperic agent is running as local system....
0 Kudos