ShaiW_hyperic
Contributor
Contributor

memcached configuration question

Hi,
We have hyperic working well in our network,
the problem is with memcached, how do I configure it to use the machine's IP ?
the memcached is listening only to the ethernet's card IP and not to localhost, is that why its not collecting data ?
We have latest version of server+client installed.
I couldn't find in the manual how to change the memcached test settings.

Thanks 🙂
0 Kudos
3 Replies
cwitt_hyperic
Hot Shot
Hot Shot

You should be able to visit the memcached resource page, go to the Inventory tab, expand Configuration Properties, and click on the Edit button. Replace "localhost" with your IP address as the hostname, and click OK. Within a few minutes, you should begin to see metrics. If you do not, verify that your view range is set to a sane value (like 8 hours)...sometimes I have things cranked out to view 48 hours or further out, and I don't see metrics I expect with new services.

If memcached was auto-discovered by HQ, the IP address should already be the hostname. Not "localhost". If things look right already, you may be having a problem with the plug-in. If your issues persist, let me know what version of memcached you are running. I am currently testing with version 1.2.2.
ShaiW_hyperic
Contributor
Contributor

Ok, Thanks
I have made sure the ip address is correct there
but still it shows memcached as unavailable.
any ideas ?

Thanks again, sorry for the "newb" questions
0 Kudos
ShaiW_hyperic
Contributor
Contributor

ok it works
what made it work ? i'm not so sure..
I think the memcache inventory settings was pointing to the correct ip
0 Kudos