hypermike
Contributor
Contributor

cant login into the hq-shell with hqadmin account -that works

Jump to solution
I can use my hqadmin account to log into the hyperic url port and do what ever I w ant. But
if I log into the hyperic server and type :

./hq-shell.sh

hq-shell::not-logged-in> login hqadmin@localhost
login hqadmin@localhost
Password:
Authentication failed

I s there length or number restiction on this password ???
I use it to loginto hyperic dashboard with NO problems.
0 Kudos
1 Solution

Accepted Solutions
cwitt_hyperic
Hot Shot
Hot Shot
Great! Hopefully that upgrade will solve and/or answer several of you
recent problems and questions. Let us know how it goes.

View solution in original post

0 Kudos
8 Replies
Mike,

What build of the beta are you using? There was a release that had this issue, but has been fixed in recent versions.

-- Jon
0 Kudos
hypermike
Contributor
Contributor
It is beta V278.. What port does it default to ??? maybe firewall issue. ?
But may not be also.

Message was edited by: hypermike
0 Kudos
The version you are running is a little bit old, so I would suggest a newer version -- that fix went in last week.

As for the port that it uses: the shell speaks to the server over the RMI connector, which is 7444.

Give the new version a shot and let us know if you still have issues.
hypermike
Contributor
Contributor
This is the latest version at SourceForge.net. I just downloaded it Wednesday. and thats
what on it download page today ?????
0 Kudos
cwitt_hyperic
Hot Shot
Hot Shot
Mike is right on this, Trav. 3.0.0-278 is the latest published version, labelled as the rc1 release.

Mike, if the fix for this bug is in a later rev, you may have to wait until the middle of this next week for the resolution.
hypermike
Contributor
Contributor
Can anyone verify that the 278 version has this BUG of NOt accepting the passwd to the login of the hq-shell. Otherwise I will continue to debug the server and its access ports. Are we sure that 7444 is the port the shell uses to talk to the server on ,if trying to login to the shell from a logged in window on the server.

Message was edited by: hypermike
0 Kudos
hypermike
Contributor
Contributor
I upgraded to 296 and NOW can login into the shell and get autheticated..!!!!
0 Kudos
cwitt_hyperic
Hot Shot
Hot Shot
Great! Hopefully that upgrade will solve and/or answer several of you
recent problems and questions. Let us know how it goes.
0 Kudos