talbrecht_hyper
Contributor
Contributor

WxGoos plugin configuration trouble

In the configuration properties of the WxGoos plugin the only configuration option to pass in is the the snmpIndexValue

I can't get any value to be accepted. I can snmpwalk the device and I can't find this value anywhere. From the WxGoos I have tried the "Unique Address" "Device Type" and the "Friendly Name" and none work. I made sure I have the latest plugin and I'm running Hyperic 3.2.2 server and agent.

The only thing I can see when I walk the device is climateSerial.1which doesn't seem to line up with the plugin xml file file which has climateSerial without the .1

Any help is much appreciated, I have been beating my head against this wall all day.

I have also tried the IP Address, 0, 1, .1, the device name, the hostname as a values without luck

The error I get is "The configuration has not been set for this resource due to : Invalid configuration: Error contacting resource: Unable to connect to SNMP Agent (ipadress:161,snmpcommunityname)"

However I know the snmp configuration is correct because I am getting availability, ip forwards and receives on the network device.


Message was edited by: talbrecht
0 Kudos
3 Replies
talbrecht_hyper
Contributor
Contributor

Some more information...
It does not appear that HQ Server is loading in the additional mib
Does anyone know where mib location is defined other than the -plugin.xml file ?
How can I troubleshoot whether or not the mib is being loaded and used?
0 Kudos
talbrecht_hyper
Contributor
Contributor

I got it to work as expected, HOWEVER...
I had to put the mib file into {agent dir}/pdk/mibs
For some reason calling out the MIB and MIBDIR in the -plugin.xml file does nothing?!?!?

Bonus! In the course of trying to troubleshoot this I created a plugin to monitor my Leibert UPS I'm grabbing Battery Percent remaining, Input and output voltages, and Output volt-Amps. It's not able to get the sysDescr etc, but that is for another post
0 Kudos
excowboy
Virtuoso
Virtuoso

Hi,
I've never had problems specifiying MIB and MIBDIR values in SNMP plugins.
When you turn debug modus on in the HQ Agent configuration you can see where the Agent is looking for the mibfiles while starting

Only Apparent Power is an enabled metric by default:

<metric name="Apparent Power"
object="powMonAppPow"
indicator="true"/>

You have can edit the plugin and add
indicator="true"
to the metrics you want to enable and deploy the plugin and the platform again.
Or you do it this way:
Go to your Monitor page of your UPS. Select "Metric Data". Check the boxes in front of the values you would like to reenable for monitoring, click on the button "Show all Metrics" fill out "Collection Interval for Selected:" and click the button with the arrow right next to it.

Mirko
0 Kudos