VMware Cloud Community
scottc_hyperic
Contributor
Contributor

Unable to import platform:

Help!
I'm evaluating Hyperic for use in our environment but have had no luck getting it working. The installation seems to proceed normally for both the server and agent I'm attempting to monitor. When I bring up the agent it is seen by the Auto Discover as expected. However when I click on the Add to Inventory button I get the Unable to import platform error seen in the attached screen shot. This is a new fresh installation. The server is running on Windows Server 2003 32-bit. The agent is running on a Windows Server 2003 64 bit server, which has me wondering if that is the issue. I noticed that there were specific 64 bit agents for linux but not a specific 64 bit agent for windows. Any help is appreciated,

thanks,
Scott
Reply
0 Kudos
6 Replies
scottc_hyperic
Contributor
Contributor

No response yet but I've done some additional testing of the issue. I installed the agent on a window xp (32 bit) box and am still getting the same error. So my error is not specific to running the agent on a 64bit windows server.

The agent/box is auto discovered successfully but when attempting to import it in the dashboard on the server I get the error message "Unable to import platform : org.hyperic.hq.common.SystemException: org.hyperic.hq.common.SystemException: Unable to find PlatformType [Win32]"

The server log shows a related error which I've excerpted here....

2011-06-23 10:21:47,649 INFO [Thread-236] [org.hyperic.hq.appdef.server.session.AIQSynchronizer@110] Queueing new platform: scurry-vm-xp.agia.in
2011-06-23 10:22:31,634 INFO [catalina-exec-1] [org.hyperic.hq.appdef.server.session.AIQSynchronizer@114] Updating existing platform: scurry-vm-xp.agia.in
2011-06-23 10:22:37,447 INFO [catalina-exec-3] [org.hyperic.hq.appdef.server.session.AIQRV_approve@93] Visiting platform: 10001 fqdn=scurry-vm-xp.agia.in
2011-06-23 10:22:37,665 INFO [catalina-exec-48] [org.hyperic.hq.appdef.server.session.AIQSynchronizer@114] Updating existing platform: scurry-vm-xp.agia.in
2011-06-23 10:22:37,681 ERROR [catalina-exec-48] [org.hyperic.hq.ui.action.portlet.autoDisc.ViewAction@157] Failed to approve AI report
org.hyperic.hq.common.SystemException: org.hyperic.hq.common.SystemException: Unable to find PlatformType [Win32]
at org.hyperic.hq.bizapp.server.session.AIBossImpl.processQueue(AIBossImpl.java:420)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)...

any help appreciated!

Scott
Reply
0 Kudos
fontato
Contributor
Contributor

I had the same problem today on a 32 bit Windows Server 2003 and fixed it.
The quickstart instructions said to install in c:\home\hyperic, but instead I had used the default directory c:\program files\server-4.5. I saw the same issue with "Unable to find PlatformType [Win32]" whenever I tried to import. I also got a 5656 Stack Error if I tried opening the agent from the AutoDiscover list.

So I uninstalled and reloaded into the c:\home\hyperic directory and the problem went away.

To uninstall, I stopped the Server and Agent Windows services and ran the server-4.5 setup.bat file with the remove flag (i.e. the command "setup.bat remove"). That ensured that the prior Windows service was totally removed - otherwise it tries to reuse the old one that points to the old program files directory.

At some point during install it asked if I wanted to overwrite prior jar files or service installations - I said yes each time to ensure the new load took precedence.

Hope that helps.
Reply
0 Kudos
fontato
Contributor
Contributor

When I did my first installation today I noted another possible factor might be where the Windows Service points to for either the server or agent path. If you run the open source server Installer setup.bat file you can specify a target directory like c:\home\hyperic, which results in the HQServer or HQAgent services pointing to the c:\home\hyperic directory.

But if you install the agent using the open source agent setup.bat file then the HQAgent service points at the directory from which you ran the installation commands.

I don't know if this contributed to the import error message, but I stopped loading agents from the stand-alone agent setup.bat file and instead loaded the agents from the server's Installer setup.bat file (using option 2 to just install the agent).

Something else to try if all else fails.
Reply
0 Kudos
scottc_hyperic
Contributor
Contributor

Hi Fontato,
thanks for your responses. This makes a lot of sense to me. However, after doing an uninstall and reinstall following your guidelines I'm still getting the same issue. So just to clarify your suggestions, by c:\home\hyperic I'm assuming you mean something like C:\Documentst and Settings\"myaccount"\hyperic? (this would be the home directory on my xp test box for instance). I'm confident that I did a complete uninstall successfully so I dont think I have any issues there....

thanks again,
Scott
Reply
0 Kudos
jvalkeal_hyperi

Don't know what is the HQ version, but I believe there was a problem if server installation path had space:

http://communities.vmware.com/message/1946077#1946077

Try to install under C:\hyperic or something similar without spaces.
Reply
0 Kudos
scottc_hyperic
Contributor
Contributor

Hey Jvalkeal,
thanks, that was indeed the problem. I had tried with a variety of versions from 4.4 to 4.5.1 and always got the same error. I tried installing both Server and Agent to different folders but they were alway under either the Program Files folder or the Documents and Settings folder(so there were alway spaces in the install path). I did an uninstall of both Server and Agent and reinstalled to c:\hyperic\... and I can now import and monitor as expected. BTW I used the win32 msi for both my Server and Agent installs....thanks again for your help. I'm guessing that Fontato was also recommending to use the literal path of c:\home\hyperic which would also solve the issue of spaces in the install path.
thanks to all,
scott
Reply
0 Kudos