wartus
Contributor
Contributor

Tomcat 6.0 autodiscovery

Hi,

I'm trying to monitor Tomcat 6.0

I have configured JAVA_OPTS and now i can monitor some basic information of Tomcat

But now i want to see all the other data hyperic can gather, so i turned on

"Auto-Discovery for Caches, DataSource Pools, and other services is ON"

but nothing happens...

can anyone help me or point me into the right direction?

thanx
0 Kudos
6 Replies
excowboy
Virtuoso
Virtuoso

Hi,

you have to make two different tasks: enable the metrics and add the views to your default view.
The first step is described here:http://support.hyperic.com/confluence/display/DOC/ui-Admin.Monitor.MetricTemplate#ui-Admin.Monitor.MetricTemplate-below

For the second step please have a look at the review guide. You'll find an very good description how to make the metrics visible.

Mirko
0 Kudos
wartus
Contributor
Contributor

Hi
thank you for answering but i think thats not what i meant,

the default tomcat 6 monitoring is working and i know that i can activate some additional reports.

What i want to monitor are extra services, that hyperic says it will auto-discover.

http://support.hyperic.com/confluence/display/hypcomm/Tomcat

Apache Tomcat 6.0 Cache service
Apache Tomcat 6.0 DataSource Pool service
Apache Tomcat 6.0 Global Request Processor service
Apache Tomcat 6.0 HTTP service
Apache Tomcat 6.0 Java Process Metrics service
Apache Tomcat 6.0 JSP Monitor service
Apache Tomcat 6.0 Servlet Monitor service
Apache Tomcat 6.0 Thread Pools service
Apache Tomcat 6.0 Web Module Stats service

Message was edited by: wartus
0 Kudos
wartus
Contributor
Contributor

anyone?
0 Kudos
tluks
Contributor
Contributor

I'm in a very simlar boat... I managed to set up tomcat for JMX monitoring for tomcat 5.5. Hyperic did not auto detect it, but saw tomcat when I entered it manually.

I'm interested in monitoring the DataSource Pool service so I tried to add it to my tomcat server by selecting "add new service." So, my datasource pool service is there but hyperic complains that it isn't configured properly.

Have you had any luck wartus?
0 Kudos
dougm_hyperic
VMware Employee
VMware Employee

There's a fix for the 5.5 issue here: http://jira.hyperic.com/browse/HHQ-1985
You'd just need to download the new plugin, copy to agent/pdk/plugins/ and restart the agent.

The service discovery should have worked for 6.0, any errors in your agent.log?
0 Kudos
tluks
Contributor
Contributor

For 5.5 I also had to put the new plugin into this server directory:

\hq-engine\server\default\deploy\hq.ear\hq-plugins

Without it, I could not turn AutoDiscovery for 5.5 on.
0 Kudos