emly
Contributor
Contributor

Running the open source & evaluation version of Hyperic simultaneously

Hi
We are evaluating both the open source and the evaluation version and we would like to run both on the same platform simultaneously. But we have a problem running the agents even if they are assigned on different ports. Any suggestions is appreciated.

thanks,
0 Kudos
3 Replies
admin
Immortal
Immortal

emly,

The agents are on different ports, and configured to point at different server URLs? When you say there are problems with the agents, what happens? Errors? Crashing?

And just to double check what you've done portwise, I assume you set the agents to different ports using the agent.properties file. If not, edit the agent.properties file in the agent directory:

# The following are the properties that the Agent recognizes:
#
# agent.listenPort
# Default: "2144"
#
# Description: Port that the agent listens on.
#

Changing "2144" to the appropriate ports.

--jeremy
0 Kudos
emly
Contributor
Contributor

Hi jeremy

thanks for your response. To be more clear, I installed the two hyperic versions as two different users in a separate path. The evaluation version uses the default ports whereas the open source version uses a different one. I've also edited the agent.properties and assign a new port. The evaluation version is running well. However I couldn't get the the open source version running. When the server is started it says....

[hyperic1@server08 ~]$ ./server-3.2.3/bin/hq-server.sh start
Starting HQ server...
Initializing HQ server configuration...
Checking jboss jndi port...
Checking jboss mbean port...
Starting HQ built-in database...
HQ built-in database started.
Booting the HQ server (Using JAVA_OPTS=-XX:MaxPermSize=192m -Xmx512m -Xms512m)...
HQ server booted.
Login to HQ at: http://127.0.0.1:5080/

and when the agent is started it says.....

[hyperic1@prematics08 ~]$ ./agent-3.2.3/hq-agent.sh start
Starting agent
- Invoking agent
- Starting agent process
Agent successfully started

[ Running agent setup ]
What is the HQ server IP address: localhost
Should Agent communications to HQ always be secure [default=no]: no
What is the HQ server port [default=7080]: 5080
- Testing insecure connection ... Failure
Unable to automatically setup: Unable to connect to HQ

The hq-install.log.debug contains the following message
fail-mbean-port-conflict-message:
Skipped because property 'server.jboss.mbean.portConflict' not set.
[antcall] Exiting /home/hyperic1/server-3.2.3/data/server.xml.

sh-setup:

BUILD SUCCESSFUL
Total time: 1 second

I used the built-in database for both versions and I made sure that they use different ports.

Thanks for your help.
0 Kudos
admin
Immortal
Immortal

emly,

Is there a firewall blocking 5080 on the agent machine? That doesn't explain the port conflict build error, but it might explain why the agent starts but can't connect.

--jeremy
0 Kudos