RDT_hyperic
Contributor
Contributor

New install errors

Hi,
I'm currently trying to install Hyperic and i'm getting the following errors.

An ERROR occurred, the installation cannot continue.
FATAL EXCEPTION at /home/hyperichq/HypericHQ/hyperic-hq-installer/installer-4.0.3/data/setup.xml:401: : The fol lowing error occurred while executing this line:
/home/hyperichq/HypericHQ/hyperic-hq-installer/installer-4.0.3/data/setup.xml:407: The following error occurred while executing this line:
/home/hyperichq/HypericHQ/hyperic-hq-installer/installer-4.0.3/data/setup.xml:531: The following error occurred while executing this line:
/home/hyperichq/HypericHQ/hyperic-hq-installer/installer-4.0.3/data/setup-db-PostgreSQL.xml:154: The following error occurred while executing this line:
/home/hyperichq/HypericHQ/hyperic-hq-installer/installer-4.0.3/data/setup-db-PostgreSQL.xml:195: The following error occurred while executing this line:
/home/hyperichq/server-4.0.3/data/server.xml:168: exec returned: 126

And it says to look at the following log which says cannot execute binary file. I've checked the permissions on all the directories and files and not sure where the cannot execute issue is at.

An error occurred trying to start the HQ built-in database. More
information may be available in the /home/hyperichq/server-4.0.3/logs/hqdb.log file.

/home/hyperichq/server-4.0.3/bin/db-stop.sh: line 8: /home/hyperichq/server-4.0.3/hqdb/bin/pg_ctl: cannot execute binary file


Thanks in advance for any help you may offer me.

Thanks,
0 Kudos
10 Replies
admin
Immortal
Immortal

Which installer package are you using? Can you give us the output of 'uname -a' ?

-Ryan
0 Kudos
RDT_hyperic
Contributor
Contributor

Package I downloaded is
hyperic-hq-installer-4.0.3-953-x86-linux.tar

The uname -a information is
Linux localhost 2.6.9-78.0.8.ELsmp #1 SMP Wed Nov 19 20:05:04 EST 2008 i686 i686 i386 GNU/Linux
0 Kudos
RDT_hyperic
Contributor
Contributor

Suggestions?
0 Kudos
RDT_hyperic
Contributor
Contributor

Going to bump this up to the top to hopefully get an answer from someone if they have error ran into this problem.
0 Kudos
RDT_hyperic
Contributor
Contributor

I guess i'll never get the answers I need for this.
0 Kudos
admin
Immortal
Immortal

It would almost seem like there might be a corrupted binary or something if it can't be executed. You can try a couple of things:

1. Download the x86_64-linux bundle
2. HQ 4.1.1 has just been released, which I recommend over 4.0.3, try that version

Charles
0 Kudos
RDT_hyperic
Contributor
Contributor

I downloaded the new 4.1.1 and still having the problem.

I see that just before the error it has the message in the /home/hyperic/server-4.1.1/logs

/home/hyperic/server-4.1.1/hqdb/bin/pg_ctl: error while loading shared libraries: /home/hyperic/server-4.1.1/hqdb/lib/libpq.so.5: file too short


the output message from the script is

--------------------------------------------------------------------------------
An ERROR occurred, the installation cannot continue.

An error occurred trying to start the HQ built-in database. More
information may be available in the /home/hyperic/server-4.1.1/logs/hqdb.log file.
--------------------------------------------------------------------------------
Waiting for server to stop...
Stopping built-in database...
--------------------------------------------------------------------------------
An ERROR occurred, the installation cannot continue.
FATAL EXCEPTION at /home/hyperic/hyperic-hq-installer/installer-4.1.1/data/setup.xml:401: : The following error occurred while executing this line:
/home/hyperic/hyperic-hq-installer/installer-4.1.1/data/setup.xml:407: The following error occurred while executing this line:
/home/hyperic/hyperic-hq-installer/installer-4.1.1/data/setup.xml:531: The following error occurred while executing this line:
/home/hyperic/hyperic-hq-installer/installer-4.1.1/data/setup-db-PostgreSQL.xml:154: The following error occurred while executing this line:
/home/hyperic/hyperic-hq-installer/installer-4.1.1/data/setup-db-PostgreSQL.xml:195: The following error occurred while executing this line:
/home/hyperic/server-4.1.1/data/server.xml:168: exec returned: 127
--------------------------------------------------------------------------------
0 Kudos
benguela_hyperi
Contributor
Contributor

I downloaded 4.1.2 and have the same error, I also created a hyperic user and tried the setup with that user but the same problem.

Server is running Ubuntu 7.10
0 Kudos
benguela_hyperi
Contributor
Contributor

I determined why my install failed. I worked it out by running pg_sql from the cli and got a more detailed error message concerning the shmmax kernel setting and the postgres postgresql shared_buffer setting so I played around with these settings and it worked. Essentialy the kernel shmmax must be set to higher than the amount in the postgres config.
0 Kudos
excowboy
Virtuoso
Virtuoso

Hi,

> I determined why my install failed. I worked it out
> by running pg_sql from the cli and got a more
> detailed error message concerning the shmmax kernel
> setting and the postgres postgresql shared_buffer
> setting so I played around with these settings and it
> worked. Essentialy the kernel shmmax must be set to
> higher than the amount in the postgres config.

therefore during the setup the installation routine asked you to run the tune-os.sh to modify the OS parameter. Did you run the script ? Did you have to change the values after you run it to fix the problem ?

Cheers,
Mirko
0 Kudos