jlbebey
Contributor
Contributor

Monitoring Jboss 3.2 with Hyperic 3.2.3

hi all,
i installed Hyperic 3.2.3 agents with embbeded JRE in linux REDHAT EL 3 and 4 for monitoring Jboss 3.2. The agent detected Jboss but when i accepted the default config and click OK, i have this error:
The configuration has not been set for this resource due to : Invalid configuration: Error contacting resource: Can't connect to MBeanServer [java.naming.provider.url=jnp%3A//127.0.0.1%3A1099,java.naming.security.principal=,java.naming.security.credentials=]: javax.naming.NameNotFoundException: jmx not bound.
In agent.properties, i put jboss.installpath=/usr/local/jboss/jboss-3.2.8.SP1 and restart agent but i have the same error.
Please, can you help me ?
Thank.
0 Kudos
6 Replies
john_hyperic
Hot Shot
Hot Shot

You need to run your JBoss with JMX. I believe the minimal JBoss config does not include this.
0 Kudos
edan_hyperic
Enthusiast
Enthusiast

> i installed Hyperic 3.2.3 agents with embbeded JRE in
> linux REDHAT EL 3 and 4 for monitoring Jboss 3.2. The
> agent detected Jboss but when i accepted the default
> config and click OK, i have this error:
> The configuration has not been set for this
> resource due to : Invalid configuration: Error
> contacting resource: Can't connect to MBeanServer
> [java.naming.provider.url=jnp%3A//127.0.0.1%3A1099,jav
> a.naming.security.principal=,java.naming.security.cred
> entials=]: javax.naming.NameNotFoundException: jmx
> not bound
.

I've only set up monitoring for JBoss 4.0, and I'm still pretty unfamiliar with JBoss in general, but here's a couple questions for you:

Is JBoss listening on port 1099? That's the default port, but all of the JBoss instances I've had to monitor were customized. You could see in a 'ps' what port they were using by looking for the

-Dcs.namingdiscovery.port=12009

parameter. That's actually how I set up Process monitoring inside HQ, because the JBoss monitoring didn't monitor JVM CPU usage. (I used a PTQL string of Args.*.eq=-Dcs.naming.port=11005,State.Name.eq=java,CredName.User.eq=jboss, FWIW)

But you might want to check using 'netstat -an' whether 1099 is actually listening.

That's what your error looks like to me anyway ... either it's not running, or you need credentials. If you need to enable JMX, well, I guess I could try to help as I need to learn about JBoss as part of my new role at work 🙂
0 Kudos
jlbebey
Contributor
Contributor

Dear john,
my jboss config has JMX entry enable. But i have the same error.
it's a command to run jboss with JMX ?
0 Kudos
jlbebey
Contributor
Contributor

dear john,
how to run Jboss with JMX ? I'am not an expert in JBoss.

thank
0 Kudos
staceyeschneide
Hot Shot
Hot Shot

Try taking a look at the documentation at http://support.hyperic.com - its completely searchable and should be able to help most of your basic JMX management questions.

The place I suggest to start is here: http://support.hyperic.com/confluence/display/DOC/JMX+Plugin+Tutorial
0 Kudos
jlbebey
Contributor
Contributor

JBoss is listening on port 1099 beacause 1099 is actually listening. also i need to enable JMX.
thank for help.
0 Kudos