jmcmike
Contributor
Contributor

IIS VHosts - Limited Ability

Hello all. On my Windows 2000 and 2003 servers running Hyperic Agent 2.7.3, IIS 5.x/6.x and all of the virtual hosts are auto-discovered but that's where the consistency ends.

On one of the 2000 servers, none of the virtual hosts are able to gather any information other than the availability. On all of the servers, the availability is all over the board with some sites showing limited availability and some sites showing down all the time when if fact none of them are down.

Does anyone here use Hyperic to track IIS servers and have you run into this?

Thanks.
0 Kudos
3 Replies
dougm_hyperic
VMware Employee
VMware Employee

Are there any errors in your log/agent.log?

Might also be useful to enable debug logging to see the HTTP responses:
http://support.hyperic.com/confluence/display/DOCSHQ27/HQ+Agent
+Configuration#HQAgentConfiguration-agentdebuglog

On Nov 15, 2006, at 6:28 AM, Justin McMichael wrote:

> Hello all. On my Windows 2000 and 2003 servers running Hyperic
> Agent 2.7.3, IIS 5.x/6.x and all of the virtual hosts are auto-
> discovered but that's where the consistency ends.
>
> On one of the 2000 servers, none of the virtual hosts are able to
> gather any information other than the availability. On all of the
> servers, the availability is all over the board with some sites
> showing limited availability and some sites showing down all the
> time when if fact none of them are down.
>
> Does anyone here use Hyperic to track IIS servers and have you run
> into this?
>
> Thanks.


jmcmike
Contributor
Contributor

I see many log entries from 6 days ago in this format with only the site names and metric names varying.

2006-11-10 01:56:08,261 ERROR [ScheduleThread] Metric Value not found: \Web Service(NameOfIISWebSite)\Current Connections
0 Kudos
cwitt_hyperic
Hot Shot
Hot Shot

It may be worthwhile to check the Configuration Properties for the vhost services that are not behaving. You can reach the properties page by clicking on the Edit button under the Configuration Properties heading on the service's Inventory tab.

Things to double-check against the IIS vhost configuration would be hostheader, path, port, and possibly ssl values.
0 Kudos