kelliott_dhap
Contributor
Contributor

Hyperic HQ 3.0.2 not detecting Apache 2 Vhosts and WL Managed Nodes

Greetings,

We've just installed Hyperic HQ 3.0.2. Our initial evaluation has lead us to believe it's quite an amazing monitoring tool!

We are having a few problems though:

* Apache 2.x Vhosts are not detected.
* While the WebLogic 8.1 Admin node, and occasionally Node Manager are detected, it does not detect our managed nodes or any applications running inside.

Is there something I must do to properly massage either of these to detect properly? Is there a way to manually add these?

Kevin
0 Kudos
6 Replies
dougm_hyperic
VMware Employee
VMware Employee


Hi Kevin,

Great to hear you like what you see so far.

You'll need to apply the following patch for WebLogic:

As for the apache vhosts, did you install the snmp module?  What version of Apache exactly and on what platform?

On Mar 26, 2007, at 4:46 PM, Kevin Elliott wrote:

Greetings,

We've just installed Hyperic HQ 3.0.2. Our initial evaluation has lead us to believe it's quite an amazing monitoring tool!

We are having a few problems though:

  * Apache 2.x Vhosts are not detected.
  * While the WebLogic 8.1 Admin node, and occasionally Node Manager are detected, it does not detect our managed nodes or any applications running inside.

Is there something I must do to properly massage either of these to detect properly? Is there a way to manually add these?

Kevin



kelliott_dhap
Contributor
Contributor

Doug,

Thanks for the reply!

Yes, I've installed the WebLogic patch. I'm just trying to figure out how to delete an auto-discovered set of servers, and rediscover them to see if it is working now.

Also, no, I did not install any SNMP module. I did not see any documentation mentioning that, nor how to do it. What steps should I do to get the SNMP module going?

Thanks again,

Kevin
0 Kudos
kelliott_dhap
Contributor
Contributor

Additionally, we're running Apache 2.0.54.
0 Kudos
dougm_hyperic
VMware Employee
VMware Employee

On Mar 27, 2007, at 9:19 AM, Kevin Elliott wrote:

> Doug,
>
> Thanks for the reply!
>
> Yes, I've installed the WebLogic patch. I'm just trying to figure
> out how to delete an auto-discovered set of servers, and rediscover
> them to see if it is working now.

You can just use Browse Resources -> Servers, check box the servers
and click the Delete button.

> Also, no, I did not install any SNMP module. I did not see any
> documentation mentioning that, nor how to do it. What steps should
> I do to get the SNMP module going?

Here's the doc on the snmp module (below the metric listing):
http://support.hyperic.com/confluence/display/DOCSHQ30/Apache+2.0+server

Note that if you already imported the "Apache httpd" type (mod_status
monitor), you'll see a different type discovered "Apache
2.x" (mod_snmp monitor) when the snmp module is installed. The VHost
services will only show up under the "Apache 2.x" type.


0 Kudos
deeboh
Enthusiast
Enthusiast

So doug does this mean that if you do not or can't install mod_snmp in your apache version Hyperic will not auto-discover or monitor on httpd services?

for some reason I can't even check the auto-discover service checkbox for my mod_status discovered apache server...

the checkbox simply returns the OFF status when i click this option?

any ideas?

Best,

Deeboh

Monitoring
server.log_track.enable true server.log_track.level Info
server.log_track.include GET|POST|HEAD server.log_track.exclude
server.log_track.files /tax/olt/www/logs/error_log,/tax/olt/www/logs/access_log,/tax/olt/www/logs/event.log server.config_track.enable false
server.config_track.files
Auto-Discovery for services is OFF
0 Kudos
dougm_hyperic
VMware Employee
VMware Employee


Hi Deeboh,

If you can't install mod_snmp, the mod_status monitor does not provide any services, just the server-level metrics you'd see with /server-status?auto
The checkbox shouldn't actually be there for the "Apache httpd" server type, that's a UI bug.

On Apr 12, 2007, at 11:07 PM, deeboh wrote:

So doug does this mean that if you do not or can't install mod_snmp in your apache version Hyperic will not auto-discover or monitor on httpd services?

for some reason I can't even check the auto-discover service checkbox for my mod_status discovered apache server...

the checkbox simply returns the OFF status when i click this option?

any ideas?

 Best,

Deeboh

Monitoring
server.log_track.enable         true    server.log_track.level  Info
server.log_track.include        GET|POST|HEAD   server.log_track.exclude       
server.log_track.files  /tax/olt/www/logs/error_log,/tax/olt/www/logs/access_log,/tax/olt/www/logs/event.log    server.config_track.enable      false
server.config_track.files      
Auto-Discovery for services is OFF



0 Kudos