amit_patil
Contributor
Contributor

Hype ric server is not able to start

Hi All,

I have installed open-source postgresql 9.1 database and after that i have installed Hyperic Server 4.6 but while starting HQ server i am unable to start it

ERROR [WrapperStartStopAppMain] [org.hyperic.bootstrap.ProcessManagerImpl@119] Command did not execute successfully (exit code = 1)

ERROR [WrapperStartStopAppMain] [org.hyperic.bootstrap.HQServer@212] Error verifying if HQ schema is valid.  url= jdbc:postgresql://localhost:5432/hyperic?protocolVersion=2, Cause: org.postgresql.util.PSQLException:

Please help me

Please let me know if more information is required.

Thanks & Regards

Amit Patil

28 Replies
admin
Immortal
Immortal

It looks like during the installation it works with the embedded database and after you start it it works with the external Postgres, I need to check why it happens, can you install with the regular tar file in the meanwhile?

0 Kudos
amit_patil
Contributor
Contributor

Ok Will do that

0 Kudos
amit_patil
Contributor
Contributor

Hi ,

I tried to install with tar.gz file but its giving the same error in bootstrap.log file.

ERROR [WrapperStartStopAppMain] [org.hyperic.bootstrap.HQServer@205] HQ DB schema is in a bad state: 'No CAM_SCHEMA_VERSION property found'. This is most likely due to a failed upgrade.  Please either restore from backups and start your previous version of HQ or contact HQ support.  HQ cannot start while the current DB Schema version is in this state

Thanks & Regards

Amit Patil

0 Kudos
amit_patil
Contributor
Contributor

Installation is sucessfull now.

1) ./setup -postgresql  ---- Started the installation with this command(I was have Open source PostgreSQL database)

In previous post which gave me error as

ERROR [WrapperStartStopAppMain] [org.hyperic.bootstrap.HQServer@205] HQ DB schema is in a bad state: 'No CAM_SCHEMA_VERSION property found'. This is most likely due to a failed upgrade.  Please either restore from backups and start your previous version of HQ or contact HQ support.  HQ cannot start while the current DB Schema version is in this state

Here i have selected 1 option which is to upgrade the HQ server database. I got the above error. I again removed the Hyperic server and installed it again using option 2 Overwrite the HQ server database. And and ....... the installation was sucessful. Below is the short detail.

Choices:
        1: Upgrade the HQ server database
        2: Overwrite the HQ server database (ERASE all existing data)
        3: Exit the installer
An HQ server database already exists at the JDBC connection URL.
What should be done with this database? [default '3']:
2

Thanks You very very much for your help Eyal and Mayan.

0 Kudos
admin
Immortal
Immortal

Thanks Amit,

There is no need to use the -postgresql flag any more because for Hyperic 5.0 Postgres is the only supported database, you should use the -full flag, it will give you some advanced installation options if you are intrested.

I will check the issue with the RPM and updtae.

0 Kudos
robertwhal6
Contributor
Contributor

thank you for your help, solution is working for me

________________________________________________________________________________________________________________________

narguile chicha | Acheter chicha | Acheter narguile

0 Kudos
darreng247
Contributor
Contributor

Hi,

Did anyone ever find the solution to

Error loading starting schema version: org.postgresql.util.PSQLException: ERROR: relation "eam_config_props" does not exist

  Position: 15


I am getting the same error on Hyperic version 5.8.0 when trying to start the service?


All the tables have not been created.

admin
Immortal
Immortal

We would probably need to see your hq-install.log.verbose file to see why your installation is failing.

Also let us know if this is the vApp appliance or a Hyperic Server with a remote database.

0 Kudos
ceefour
Contributor
Contributor

the ?protocolVersion=2 in the JDBC URL is mandatory as of Hyperic HQ v5.8.1. Do not remove it!

I tried to remove it on first install (since even protocolVersion 3 is quite old, for PostgreSQL 7.x and we're on PostgreSQL 9.1+ world now!) and it fails with message:

Error loading starting schema version: org.postgresql.util.PSQLException: ERROR: relation "eam_config_props" does not exist

0 Kudos