sothy97
Contributor
Contributor

Hadoop plugin

Hi!

I am deploying the plugin for hadoop based in this url:

https://github.com/hyperic/hq-hadoop/blob/master/hadoop-plugin.xml

Since I am using hadoop-0.20.2, I changed the class as available in the

corresponding version. For

example, org.apache.hadoop.hdfs.server.namenode.NameNode

However, I debuged* via sigar interface,*  ps State.name.sw=java,

Args..eq=server.namenode.NameNode,Args..sw=-Dhadoop.home.dir=

It gives the result. detect the server. I got ::

8670    ubuntu  oct.16  1.2G     63M    9.0M    S       31:1

java:org.apache.hadoop.hdfs.server.namenode.NameNode

However, When I debuging via * this command.*

/usr/local/java/bin/java -jar hq-pdk-4.6.6.jar -Dplugins.include=hadoop -m

discover -a metric -Dlog=debug

0 server detected. And I noticed one debug line like this.

*DEBUG Running AutoServerDetector for: Hadoop Name

Node*

*DEBUG

ptql=State.Name.sw=java,Args..eq=org.apache.hadoop.hdfs.server.namenode.NameNode,Args..sw=-Dhadoop.home.dir=

matched pids=[[J@5097eded]*

ERROR AutoScan failed for Hadoop Name Node

java.lang.IllegalArgumentException: Unable to resolve config include=jmx

  •        at

org.hyperic.hq.product.pluginxml.LateBindingConfigSchema.getOptions(LateBindingConfigSchema.java:62)

*

  •        at

org.hyperic.hq.product.ServerDetector.mergeConfigDefaults(ServerDetector.java:948)

*

  •        at

org.hyperic.hq.product.ServerDetector.mergeConfigDefaults(ServerDetector.java:941)

*

  •        at

org.hyperic.hq.product.ServerDetector.mergeConfigDefaults(ServerDetector.java:999)

*

  •        at

org.hyperic.hq.product.ServerDetector.setProductConfig(ServerDetector.java:1010)

*

  •        at

org.hyperic.hq.product.DaemonDetector.newServerResource(DaemonDetector.java:200)

*

  •        at

org.hyperic.hq.product.jmx.MxServerDetector.getServerResource(MxServerDetector.java:383)

*

  •        at

org.hyperic.hq.product.jmx.MxServerDetector.getServerResources(MxServerDetector.java:459)

*

  •        at

org.hyperic.hq.autoinventory.scanimpl.NullScan.scan(NullScan.java:81)*

  •        at org.hyperic.hq.autoinventory.Scanner.start(Scanner.java:198)*

  •        at

org.hyperic.hq.autoinventory.ScanManager.mainRunLoop(ScanManager.java:141)*

  •        at

org.hyperic.hq.autoinventory.ScanManager.access$000(ScanManager.java:41)*

        at

org.hyperic.hq.autoinventory.ScanManager$1.run(ScanManager.java:107)

I think there is two things.* One is with hadoop.home.dir. Second is

matched pids=[[J@5097eded].*

So I changed hadoop.home.dir in pulgin.xml as /home/ubuntu/hadoop-0.20.2. I

didnt get the execption, But again I got the 0 servers detected.

I wonder with above two things. Am I right or not?

Do you have any working xml file? thanks

Please help me if you have any idea.

Best regards

Sothy

0 Kudos
1 Reply
laullon
VMware Employee
VMware Employee

Hi,

The best way to solve this problem is by replacing this:

<config include="jmx">
    <option name="process.query" description="Process query" default="${process.query}"/>
</config>

by:

<config>
    <option name="process.query" description="Process query" default="${process.query}"/>
    <option name="jmx.url" description="JMX URL to MBeanServer" default="${jmx.url}"/>
    <option name="jmx.username" description="JMX username" optional="true"/>
    <option name="jmx.password" description="JMX password" optional="true" type="secret"/>
</config>

German.
0 Kudos