oalvarez_hyperi
Contributor
Contributor

Does Hyperic have support for EJB3 beans on JBoss 4.0.4?

I've installed Hyperic v.2.7.5 server and agents on Windows XP Pro. platforms for evaluation. We have an EJB3 application deployed on JBoss 4.0.4. We see the "EJB3 Service" discovered and it's single metric of "availability", however, we don't see any of the "... Session EJB Service"s as listed in the link below*. Are these metrics available for EJB3, annotation based, Session Beans? If so, how can we obtain those metrics, as they aren't automatically discovered?

Thanks!

*http://support.hyperic.com/confluence/display/DOCSHQ27/JBoss
0 Kudos
4 Replies
oalvarez_hyperi
Contributor
Contributor

The answer is "The EJB3 implementation (is) not GA yet".
So, no Hyperic does not support EJB3 beans on JBoss 4.0.4.
0 Kudos
dougm_hyperic
VMware Employee
VMware Employee

We do support EJB3 beans on JBoss 4.0.4, but we can only provide
inventory and availability until JBoss implements JSR-77 statistics
for EJB3 beans:

http://jira.jboss.org/jira/browse/JBAS-2057

On Dec 12, 2006, at 1:01 PM, oalvarez wrote:

> The answer is "The EJB3 implementation (is) not GA yet".
> So, no Hyperic does not support EJB3 beans on JBoss 4.0.4.


0 Kudos
oalvarez_hyperi
Contributor
Contributor

> We do support EJB3 beans on JBoss 4.0.4, but we can
> only provide inventory and availability until JBoss implements
> JSR-77 statistics for EJB3 beans:
>
> http://jira.jboss.org/jira/browse/JBAS-2057

Thanks for the info.
Which Hyperic version is "ready" to support this? That is, if JBoss implements JSR-77 tomorrow and I upgrade, will my Hyperic 2.6.27 pick up the metrics, or do I have to upgrade to a particular Hyperic version?

Thanks.
0 Kudos
dougm_hyperic
VMware Employee
VMware Employee

We won't be able to add support to the plugin until we have access to
the implementation to develop and test against. Once JBoss adds
support, it'll be a quick update to our jboss-plugin.jar which you'll
be able to drop into your existing installation. We'll update our
plugin for the 2.6, 2.7 and 3.0 releases of HQ.

On Jan 3, 2007, at 4:26 PM, oalvarez wrote:

>> We do support EJB3 beans on JBoss 4.0.4, but we can
>> only provide inventory and availability until JBoss implements
>> JSR-77 statistics for EJB3 beans:
>>
>> http://jira.jboss.org/jira/browse/JBAS-2057
>
> Thanks for the info.
> Which Hyperic version is "ready" to support this? That is, if JBoss
> implements JSR-77 tomorrow and I upgrade, will my Hyperic 2.6.27
> pick up the metrics, or do I have to upgrade to a particular
> Hyperic version?
>
> Thanks.
>