Digimatic
Contributor
Contributor

Can't install on RH6.4 with a Standalone DB

I'm new to Hyperic but have a customer who wants us to purchase and deploy HQ Enterprise over a largish AWS environment. Naturally they want to see the evaluation running before they commit though.

There is nothing much special about the AWS RH6.4 image so I can't understand why this doesn't work. Installation goes well with both built in and standalone DB's with builtin DB I can start the server and all seems well. With the standalone Prostgres the installation completes and I can see the DB is populated with the initial data but the server starts and then stops seconds later.

I've followed the installation guidelines for both the tarball and rpm versions (the full versions with included JRE) to the letter, naturally I have upgraded postgres to 9.1 (and even tried 9.2 in desperation), started again from clean images not installing with the built in DB first etc.

The slightly strange thing as is you can see in the bootstrap logs below I am gettingdbType=11, targetDB='null' which is slightly odd...then I get what looks to be a successful DB upgrade followed by the server exiting with an undeclared error...then it just starts the shutdown process. If I try to restart the log looks exactly the same (including the DB upgrade messages)

All the config points to a postgresql instance on the same host...I have confirmed that pgsql can log in as the defined user and password...and as I say something does manage to populate the database "HQ" with tables. Going round in circles with this now with pressure from the client to deliver it and a ticking away evaluation license.

** bootstrap log **

org.hyperic.tools.ant.dbupgrade.SST_DirectSQL$Statement@165] dbType=11, targetDB='null'
2013-08-06 13:28:25,854 INFO [main] [org.hyperic.tools.ant.dbupgrade.SST_DirectSQL$Statement@165] >>>>> Processing statement desc=[null] SQL=[create table if not exists EAM_ENCRYPTION_KEYS (encryption_key varchar(2000) not null, creation_date timestamp primary key default now()) ]
2013-08-06 13:28:25,855 INFO [main] [org.hyperic.tools.ant.dbupgrade.SST_Insert@165] >>>>> Inserting into EAM_ENCRYPTION_KEYS insert into eam_encryption_keys (encryption_key) select ? where not exists ( select * from eam_encryption_keys where encryption_key = ? and creation_date = (select max(creation_date) from eam_encryption_keys))
2013-08-06 13:28:25,867 INFO [main] [org.hyperic.tools.ant.dbupgrade.DBUpgrader@165] DATABASE SUCCESSFULLY UPGRADED TO 3.219
2013-08-06 13:28:25,887 INFO [WrapperStartStopAppMain] [org.hyperic.bootstrap.ProcessManagerImpl@122] Command executed successfully (exit code = 0)
2013-08-06 13:28:26,407 INFO [WrapperStartStopAppMain] [org.hyperic.bootstrap.HQServer@198] HQ DB schema: 3.219
2013-08-06 13:28:26,410 INFO [WrapperStartStopAppMain] [org.hyperic.bootstrap.HQServer@151] Booting the HQ server...
2013-08-06 13:28:26,434 ERROR [WrapperStartStopAppMain] [org.hyperic.bootstrap.ProcessManagerImpl@119] Command did not execute successfully (exit code = 1)

after that it just calls wrapper-stopper and shuts down.

Tried opening a support call with vmware went round in circles with them but they point blank refuse to help support a evaluation installation...a strange and disappointing anti-sales practice I must say...why would you not help someone who is poised to be spending £1000's on your software ?...even more of a shame as I have been using vmware products from when the original virtualisation product was pre 1.0 and I remember their support being a lot better than this.

So now I turn to the ever faithful community...can you guys help me ?

0 Kudos
1 Reply
admin
Immortal
Immortal

Do you see the server.log file? If so, can you attach it?

0 Kudos