bcm_hyperic
Contributor
Contributor

Apache 2.2 server configuration problem

I manually created an Apache 2.2 server in HQ and configured SNMP and response time logging as per the instructions on the config properties page, but SNMP doesn't actually appear to be working, as I get this error message when trying to save the config properties:

"The configuration has not been set for this resource due to : Invalid configuration: Error contacting resource: Unable to connect to SNMP Agent (127.0.0.1:1610 v2c,public)"

None of the instructions on the config properties page, those at http://support.hyperic.com/display/hypcomm/Apache+2.2+server, or those in <agent_dir>/product_connectors/snmp-1.0.2/README seem to be up to date, as they all give me various instructions for running an snmpwalk binary which doesn't exist.

I tried running 'snmpwalk localhost:1610 public' using my system's snmpwalk, but that times out. I thought about adding -M to that, but I couldn't figure out what to put as an argument for it. I even tried telnetting to port 1610, but nothing's listening on that port.

And yes, I did restart Apache, several times 🙂

What could be going wrong? How can I further troubleshoot this?
0 Kudos
1 Reply
Azevedo_hyperic
Contributor
Contributor

My problem is similiar.
I have files snmpcommon.so, snmpmonagt.so, mod_rt.so in the modules folder.
I created var folder and configured the snmpd.conf file.

I added to httpd.conf:
LoadModule snmpcommon_module modules/snmpcommon.so
LoadModule snmpagt_module modules/snmpmonagt.so
SNMPConf conf
SNMPVar var

ExtendedStatus On
<Location /s
SetHandler server-status
Order deny,allow
Allow from 127.0.0.1
</Location>

The "http://${server.name}:${port}/server-status" works fine.
But, I' can't connect Hyperic to Apache 2.0. Please see my agent.log.

Thanks,
Azevedo
0 Kudos