ahornacek
Contributor
Contributor

Problems displaying the dashboard in VCM 5.6

Has anyone seen this error and know the quickest way to resolve it?  I've built a demo version of VCM5.6 using the Demo Key for the latest Operations Manager.  All installed on a Windows 2008 R2 VM with SQL 2008 R2.  I was able to finally get a good clean install in a two-tier configuration.  SSRS for Sql 2008 R2 is working perfectly fine.  I can browse to the location "http://servername/reportserver" and the reports are listed for the ECM Reports.  I can click on the reports, and they come up flawlessly.  But, when I'm in VCM, and I go to open up the dashboard that points to the same report, I get an error:

An error has occurred during report processing.

  • The request failed with HTTP status 401: Unauthorized.

How do I fix this?  I can't seem to find the error in any of the eventlogs, or VCM logs or even SSRS or IIS logs.  Why do the ECM reports come up fine but not the VCM Dashboards?  Any help would be greatly appreciated.  I'm attaching a small screen shot of the Dashboard selected and the error displayed.  Also, if you click on "Export" you get the same error but in a pop up window. 

0 Kudos
2 Replies
admin
Immortal
Immortal

This is generally a permissions issue associated with the collector account being used, not necessarily with the logged in user account. When you browse to the RS site, you're using passthrough auth from the logged in windows user. This is not how SSRS authentication is working in the console. First, check that you enabled basic authentication in the RS VMware KB: SSRS authentication must be configured in two-tier and three-tier installation environmen...

If you have the necessary authentication settings, let us know so we can go to the next steps.

0 Kudos
admin
Immortal
Immortal

You need to edit the rsreportserver.config file under Program Files\Microsoft SQL Server\MSRS10_50.MSSQLServer\Reporting Services\ReportServer.

Find the Authentication section and remove the <RSWindowsNTLM/> and <RSWindowsNegotiate/> entries. Replace these with an <RSWindowsBasic/> entry.

This change takes effect as soon as you save the file.

Alternatively, if you don't want to use Basic authentication, you can configure Kerberos. This is documented in the installation guide. It's a bit of an involved process.

0 Kudos