ShyamliNair
Contributor
Contributor

while installing SEG V2 getting below error ' Error while performing action LOAD_CONFIG_FROM_API'

While installing seg V2 getting below error


Error while performing action LOAD_CONFIG_FROM_API. 
Returning exit code 1.
com.airwatch.seg.exception.SegException:
Unable to getSegConfig SEG config from API
https://awqads.ril.com/api/mem/activesync/gatewayinstallationsettings?memconfigguid=82547ca7-04f5-47...

All pre-requisite is completed...we are able to reach api server from seg. regards, Sudeep Shetty

Labels (1)
0 Kudos
6 Replies
LukeDC
Expert
Expert

The ID you are using during the setup has rights to the API as well?

0 Kudos
Phat8
Contributor
Contributor

We have the same issue.
Segadmin account has API rights
0 Kudos
GillesRemy
Contributor
Contributor

We have the same issue also.
Did you find how to solve this?
0 Kudos
KonstantinosLei
Contributor
Contributor

Was this solved?

0 Kudos
Stansfield
Enthusiast
Enthusiast

This usually means some part of api communication is blocked, as a reminder it is not the same api as for seg v1 it now uses rest api, so I would try logging into both the console and portal to verify the connection (needs api and console access), you can be able to reach the server and still have things blocked for a full handshake (we know from experience).  Also it may be wise to remove the mem config guid string from your post these forums are public
0 Kudos
TerryDavisBTSM
Contributor
Contributor

I got a similar error when installing SEG v2, was able to resolve by logging into the API account on the Airwatch console. This also prompted to change the password as they are not able to be set to not expire in Airwatch. Hope this helps 🙂
0 Kudos