glennc1968
Contributor
Contributor

upgrade from 9.2.2 to 9.6

So i have questions on upgrading versions.  In reading different posts. it look like a upgrade path will be as follows? 
backup the db of course,  but than I need to upgrade the db to 9.3  But it seems i only have to skip the application upgrade to 96.  I wont have to do step upgrades of the application 9.3-9.4- ect. 
Am i on the right track? 
Labels (1)
0 Kudos
34 Replies
ThomasCheng
Enthusiast
Enthusiast

That's amazing Sebastian. I wouldn't dare upgrading SEG to SEG v2 with this upgrade just yet. What's your experience like and did you uninstall SEG classic first prior to SEG v2?
0 Kudos
nessaja
Enthusiast
Enthusiast

Hi Thomas,
the Migration classic to v2 is very simple and stable.
First, you must Change the MEM-Profile to v2. Than I've installed the SEGv2 on the same System as the seg classic still runs (parallel).
After the Setup has completed. disable the IIS (Services) and Restart the Server. The Impact for the users was just the reboot 3 min.
Last step, I've uninstalled the SEG Classic and the IIS. That's all.
Most of pur Customer are running SEG classic on Server 2008R2. We're migrating the SEG v2 to Server 2016.
0 Kudos
ThomasCheng
Enthusiast
Enthusiast

Thanks Sebastian. I will give it a shot after my upgrade to 9.7 in production. I will sure write a blog post about the SEG upgrade.
0 Kudos
glennc1968
Contributor
Contributor

so last night i tried a trial run to upgrade to 9.6   I got a gem cert installer error,   and a migration tasks runner error?   I dont see how to's on how to fix either?   Has anyone seen these?  
0 Kudos
MichaelSchn
Enthusiast
Enthusiast

Hello together,
First I want to thank you guys for your tips for the update to 9.6.
I did the update yesterday from 9.2.3 to 9.6 (unfortunately 9.7 deployement was not ready as I planned the update).
I did the steps described by you, so I updated the DB first to 9.3 and then directly to 9.6. After this I updated the Application servers directly to 9.6. All services could be started and everything looked fine. Finally I applied the 9.6.0.8 patch like described by VMware.
Everything went smooth and without any complications.
The content Gateway seems not to have an update so far for 9.6, so I let it on version 9.2.3.

Next week, I will do the update on our multi tenant environment, with a LOT of devices on it from 9.2.3 to 9.6.0.8, hopefully it went smooth like this yesterday ^^.
BR
Michael
0 Kudos
ThomasCheng
Enthusiast
Enthusiast

Nice work Michael. Is it your very first upgrade?
My colleague and I finished upgrading our production environment spanning across two sites last Friday night into Saturday morning. Now we are on 9.7.0.9 and already felt we are behind as 2018.10 is out.
I spoke with VMware support and the version of Content Gateway and many other auxiliary components won't match up with the console version as many of them will soon be retired. For instance, Content Gateway will be merged with UAG, and SEG classic will be replaced by SEG 2.0.
0 Kudos
MichaelSchn
Enthusiast
Enthusiast

Hi Thomas,
No, it was not my first update, I did several in the past.
But from 9.0 to 9.1 there was a strange problem during the update, and the worst case happened, all of the devices from an on-premise customer were unenrolled. As you can imagine from this update on I am a bit nervous when I have to do an update ^^ (I also saw a lot of people had problems with 9.0 to 9.1 and specially with 9.1).
Specially because the update intervals are crazy at the moment and the changes are huge a lot of research is necessary.
Also because the documentations are not so fast written like the updates are released :).

Oh thanks for the hint with the content gateway, that explains a lot.
0 Kudos
ThomasCheng
Enthusiast
Enthusiast

I know ' exactly'  what you mean Michael. You can never ever keep up. Worst of all, there's not much details about the patches themselves other than the fact that they are cumulative. What's holding you from upgrading to 9.7 especially if you have iOS devices to take advantage of remote view?
0 Kudos
MichaelSchn
Enthusiast
Enthusiast

Good to know that I am not the only one who has a bit doubts if this strategy from vmware is good :).
At the moment the only thing that is holding me from installing 9.7 is that I have to announce another maintenance window and this is not possible for the customer at the moment... maybe later this year or beginning next year, 9.6 is working great so far so I have no stress.
But my testenvironment will defenitely get 9.7 in a few days ;).
0 Kudos
MartinHnow
Contributor
Contributor

Nice work, dudes. But what about to find the right files. I found the FULL Installer for 9.7 I found the Patch-Installer 9.7.
But where is the DB Upgrade. First i have to go to 9.3 and than on. Where it is? In the Full-Installer of 9.3? -> Perhaps that:


https://resources.workspaceone.com/view/5zvdd9ldn7mlzd3723f6/en



Thank you!

0 Kudos
ThomasCheng
Enthusiast
Enthusiast

Martin, I assume you can use some guidance with upgrading to 9.7?
You will need to upgrade your DB to 9.3 with the link you mentioned. Then, execute the DB package within the 9.7 full installer to upgrade the DB to the latest version.
0 Kudos
administradorwi
Contributor
Contributor

Hi, we have Airwatch 9.2.3. We want to upgrade to the last version (1810). As we can see, this is the procedure:
- Stop all servers Services
- Backup servers (as they are virtual machines, we will do a snapshot)
- Backup Database
- Upgrade database to 9.3
- Upgrade database do 1810
- Upgrade all servers to 1810
- Start Services

To apply the last patch for 1810 version:
- Stop all servers Services
- Backup servers (as they are virtual machines, we will do a snapshot)
- Backup Database
- Run .sql file to the database
- Execute installer in all servers
- Start all Services

Do you think that it's ok?
Thanks!
0 Kudos
JoeTingley
Enthusiast
Enthusiast

Hi administrador w. - That looks like the procedure I would use going from that version provided you don't have any extra services (SEG, etc).
For those of you who do use other services, I'm on 9.6.0.8 running SEG classic and Content Gateway and thinking about the next steps. It sounds like SEG Classic is EOL and I'll have to transition to SEG V2. Anyone made that jump yet and have any insight? How about content gateway?
0 Kudos
Hashj71
Contributor
Contributor

Hi administrador w. Did you face any issues after installing 18.10 from 9.2.3? I have the same environment i.e. 9.2.3.28 and want to upgrade my test to 18.10? Suggestions are appreciated? We are a very big enterprise and what to know what are the pros and cons in this. However, as this is the latest version, we are avoiding upgrading to 18.10 and looking for 9.7. What is the latest version of 9.7.x? Thomas/Luke?

0 Kudos
chengtmskcc
Expert
Expert

Hey Harsh, I've not been active on the forum until now and just saw this post when preparing to migrate my SEG from classic to V2. Where are you with your upgrade?
0 Kudos