VMware Workspace ONE Community
Apptreematt
Contributor
Contributor

Workspace ONE Web - Custom URL Scheme Support

We have a native iOS application that is deployed via Airwatch. To login to the application, we are opening the "Workspace ONE Web" browser using the custom url scheme:

awbs://identityprovider.apptreeio.com/....

This opens the Airwatch web browser and the user is able to successfully sign in. 

However, after signing in the identity provider performs a redirect to a custom url scheme registered to our application.

apptree.io://oauthredirect?....

In other web browsers such as Safari or Chrome, this launches our native application and the login process is complete. In the WorkSpace One Browser, the browser does nothing upon receiving this redirect. 

We pulled the logs from the browser and I see the following logs below. In these logs you can see that it's receiving the URL with the custom scheme of apptree.io:// but it appears it's attempting to load it as a web page rather than launching our native application.

Does the Workspace ONE Web browser support launching custom url schemes? If so, is there a configuration we need within Airwatch to support this?

You can see from the screen shot attached that we have configured our application in the "Allowed Applications List"

 

qZ9HDyarZQKWd16A1f-097Dd7-AwAA__8BAAD__--oy1CmBgAA&sessId=8006 to <NSMutableURLRequest: 0x280ad17d0> { URL: apptree.io://oauthredirect?code=5d3e7719-60cf-4e7b-9b95-6b95acffe31b&state=rCm1aykLS9QHXOSu0wU76r71sWieThaEC_5oCTIxZds }2021-11-30T23:43:08.963 [I] Line : 130 logoutput(message:) 2021-11-30T23:43:08.963 [BrowserSDK:-] [V] Line : 287 urlSession(_:task:didCompleteWithError:) [URLProtocol] Ignoring NSURLErrorDomain/NSURLErrorCancelled in didCompleteWithError
2021-11-30T23:43:08.964 [I] Line : 130 logoutput(message:) 2021-11-30T23:43:08.964 [BrowserSDK:-] [V] Line : 205 webView(_:shouldStartLoadWith:navigationType:) [BrowserSDKUIWebView]: should start Loading: apptree.io://oauthredirect?code=5d3e7719-60cf-4e7b-9b95-6b95acffe31b&state=rCm1aykLS9QHXOSu0wU76r71sWieThaEC_5oCTIxZds
2021-11-30T23:43:08.964 [V] Line : 244 recordAnalyticsEvent(withName:value:) BrowserWebsiteLogging is disabled. Hence ignoring sdk analytics event.
2021-11-30T23:43:08.978 [I] Line : 130 logoutput(message:) 2021-11-30T23:43:08.978 [BrowserSDK:-] [E] Line : 258 webView(_:didFailLoadWithError:) [BrowserSDKUIWebView]: didFailLoadWithError The URL can’t be shown
2021-11-30T23:43:08.979 [I] Line : 130 logoutput(message:) 2021-11-30T23:43:08.979 [BrowserSDK:-] [E] Line : 258 webView(_:didFailLoadWithError:) [BrowserSDKUIWebView]: didFailLoadWithError Frame load interrupted

 

Reply
0 Kudos
2 Replies
vinothkumarrk
Contributor
Contributor

We are facing the same issue, is it working for you now? If it's working, could you please let us know the steps to fix this error. Thank you.

Reply
0 Kudos
verma1979
Contributor
Contributor

We are experiencing same issue.

We do use weblink with(“airwatch://) protocol to redirect the requests to Intelligent Hub in Airwatch. The weblink launches Intelligent Hub and It works fine when default browser in the device is set to safari. This is not working when the device's browser is set to other than Safari. e.g chrome or edge.

The actual link is “airwatch://conditionalaccess?partner=microsoft” which will trigger Safari to open the Hub app. My default browser is Edge which interprets it as an HTTP link, not an “airwatch” link. Can we look into how to either force it to open Safari or make sure it will work with Chrome and Edge?

Reply
0 Kudos