FelipeSilvaFeli
Contributor
Contributor

Workspace ONE Remote Assist

Hi everyone,

I am trying to install Workspace ONE Remote Assist based on the documentation VMware provides. I have done all requisites, generate certificates and so on. When I am installing the installation is aborted saying : Error: DTP Service Not Active.

Does anyone know what is that? I tried many times, different servers (virtual) but always the same issue.
Labels (1)
9 Replies
iamtonystark
Contributor
Contributor

I'm having the same issue. Any 1 know about this?

0 Kudos
jsheetsaw
VMware Employee
VMware Employee

Hello FelipeSilvaFelipeSilva1 and iamtonystark,

I have a few questions to help understand where the issues may be arising from:

  1. Are you deploying a Core Server (all-in-one) or splitting up your Connection Proctor and Core/App/Portal services as described here?
  2. After running the installer, is IIS active on the target server(s) and listening on your configured ports (443 by default for the Core/App/Portal services which the DTP service belongs to)?
  3. In your target SQL server database, there is a ApAdmin.dbo.services table.  If you query all entries (SELECT * FROM ApAdmin.dbo.services), do you see an entry for your target server? And if so, does the active column report as true or false?

In a multiple server deployment where your Connection Proctor (CP) and Core/App/Portal (CAP) servers are separated, this is likely caused by the other services being unable to reach the DTP (Data Tier Proxy) service which resides on the server where the Core/App services are installed.  This could be firewall or routing issues, could you please verify that the target server(s) can reach each other over the intended ports?

In a single server deployment where everything is on one server, I would verify that IIS is installed and properly listening to your configured ports for the Core/App services (443 by default).  I would also verify, as described above, that your ApAdmin.dbo.services table shows your server and shows it as active, otherwise, Assist will be reaching out to the incorrect server or assuming the entire server is offline and cannot be contacted.

Thank you,
Justin

0 Kudos
JanekKardynal
Contributor
Contributor

Hi!

We had the same issues here and after going throught several logs (and the SQL log) we found out that the SQL server must have windows AND sql authentication activated (had only windows before). After that the DTP service was installed correctly. Also make sure that you have deleted the Default Web Site and Application Pool in IIS to avaoid port conflicts during the installation process.

jsheetsaw
VMware Employee
VMware Employee

Agreed - great suggestions, JanekKardynal. Ensuring that the default IIS bindings and application pool are not conflicting is a good check.  If you have not inspected the installer logs, this would be a place to start to see which piece is failing. 

0 Kudos
xyz20010
Contributor
Contributor

Hi jsheetsaw.

      Do you know the Assist's default administrator&password? I can't find in the guide. Thanks!

Best Regards

James

0 Kudos
jsheetsaw
VMware Employee
VMware Employee

Hi James, which step are you at for configuring Assist?  If you've already run the installer and setup the database, I would recommend setting up your Workspace ONE Assist integration in the Workspace ONE UEM console which allows your administrators in UEM to launch remote management sessions with Assist without using separate credentials:

Thank you,

Justin

0 Kudos
xyz20010
Contributor
Contributor

Hi Justin,

          Thanks for you reply.

           We have  finished the installer and config in the UEM Console.

           But when we tested on android&ios device, there’s an error in the first step:

          arm.pic

          We run the  installer  followed by the official guide.

          Would you like give me some advice to troubleshooting this error?  In china this is the first case on-premise deployment,  it’s a challenge. Thanks!

          Best Regards

         James Xie

0 Kudos
chengtmskcc
Expert
Expert

I suggest you check and make sure the proper firewall ports are open to allow communication to go through properly.

0 Kudos
jsheetsaw
VMware Employee
VMware Employee

Hi xyz20010,

In addition to chengtmskcc's recommendation of checking your firewall ports (see this article for on-premises ports: On-Premises Configurations, Network and Security Requirements), please see this article (Troubleshooting Workspace ONE Assist) which may give you some ideas on what can be misconfigured.  The device is currently unable to register with Assist so there is likely an issue communicating with your Assist server(s).

Can you specify which verions of the following you are using?

  • Workspace ONE UEM
  • Workspace ONE Intelligent Hub agent (on your devices)
  • Workspace ONE Assist
  • Workspace ONE Assist app agent (on your devices)

Have you tried using the Register Device button on this UI? If so, do you receive any errors or additional messages? You can also view device registration attempts in the Workspace ONE UEM console by navigating to the Device Details page > More > Troubleshooting.

If you have not seen our Reference Architecture guide on TechZone, we also go over installing Assist on-premises which you may find useful: VMware Workspace ONE and VMware Horizon Reference Architecture | VMware.

Thank you

0 Kudos