EmilKjeldsen
Contributor
Contributor

Windows 10 Enrolment error: 3999

Hey all, 

We have 0 experience with W10 devices, as we have been Mac only till now. 

When enrolling into Workspace ONE through Intelligent Hub app, we have some users who see the error below. Has anyone found a way to resolve this?  

wsone-error3999.png

7 Replies
Igor_P
Contributor
Contributor

Hi!

We get the same error few weeks ago with some computers which was used without WSOne before. We didn't find a way to resolve. OS reinstall helps of course, but I'm sure that there might be another way to solve.

The only thing was changed on WSOne side is UEM console upgrade to 2101 few weeks ago. And which version do You have?

Our log shows:

Error AW.Win32.Utilities.MDMRegistration.DmEnrollmentHandler.DecodeUdidKey Error Getting Udid Key*** EXCEPTION ***

System.IndexOutOfRangeException: Index was outside the bounds of the array. at AW.Win32.Utilities.MDMRegistration.DmEnrollmentHandler.DecodeUdidKey(String certSubject) Method: AW.Win32.Utilities.MDMRegistration.DmEnrollmentHandler.DecodeUdidKey;

Error VMware.Hub.Win32Agent.Enrollment.Business.Execution.Implementation.DmReadCertificateStep+<Execute>d__5.MoveNext SOURCE: [DmReadCertificatePage], ERROR_CODE: [3999], ERROR_MESSAGE: Unknown Exception. Error code : 3999., ERROR_RESPONSE: System.ArgumentNullException: Value cannot be null.

Will look for other answers.

0 Kudos
mturcot
Contributor
Contributor

I am having the same issue with error 3999 when trying to enroll a windows 10 machine.

 

Any solutions?

0 Kudos
TvvN
Contributor
Contributor

Same error with azure joined Windows 10 device.

Have you found a solution yet?

0 Kudos
gowdaman_n
Contributor
Contributor

Please try the below steps and check:

  1. Uninstall intelligent hub
  2. Delete the below registry key\folders
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EnterpriseResourceManager\Tracked
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enrollments
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Provisioning\omadm\Accounts
  3. Reboot the device
  4. Install intelligent hub and enroll
TvvN
Contributor
Contributor

Thank you, that worked!

Is this a known issue with inteligent hub? I also tested it with a newly installed laptop.
Even then it is necessary to remove the registry settings for it to work.

0 Kudos
csolonas
Contributor
Contributor

Hey,

It worked for me!! Thank you

0 Kudos
gowdaman_n
Contributor
Contributor

Devices are managed or were managed by other MDM's (Azure & Google Workspace) in my scenarios.

I have attached a screenshot for reference. But I found this solution -

  1. Make sure there no entries under "Access work or school"
  2. Then Enroll with Intelligent HUB
  3. Then you can connect to Azure AD or Google Workspace IDP.

This worked in my situation and definitely, this is not a solution but you can use this as a workaround