OskarRodriguez
Contributor
Contributor

Samsung XCover 4 with Launcher and access to phone

Hi,

I have a Samsung XCover4 that is enrolled using Samsung KME for easy enrollment and the into Android Enterprise for getting apps without a Google ID.
This device is configured to use the Launcher and this is working just fine.
I am trying to give the users access to the phone and the physical buttons on the device. This seems a bit problematic.

The phone is working, I am able to call out. But when the device receives a call and the launcher is active, no phone app appears for the user to accept the call. When the device is receiving a call when the device is in standby the phone app appears and the users are able to answer the app.
How to solve this.

Also: The physical buttons. How to activate them? The home button the the app manager. The home button is replaced with a floating button. can this be removed? Can I assign the app manager to the button? If not, is it possible to get the app manager as a shortcut on the canvas?

Hope somebody has some answers. ๐Ÿ™‚

Thanks

Oskar Rodriguez
Labels (1)
9 Replies
OskarRodriguez
Contributor
Contributor

Got it figured out. Needed to add the following XML code in a Custom profile.





This code allows the status bar on the device and as the phone is coming from the statusbar when receiving an incoming call this needs to be visible for the user.
0 Kudos
VegardAarseth
Enthusiast
Enthusiast

Hi. I have the same phone and the same issue. The physical back button work. But not the home button. I have the same floating button on screen.

I also have the same issue with incoming calls etc. How did you solve this? I can't see any xml code. I used to fix this by adding a hidden app (incallui), but that's not working. Not sure if it's because of the device (Xcover 4) or the fact that this is a work managed device enrolled using QR code.
0 Kudos
MarvP
Contributor
Contributor

Hey I got the same issue with Work managed devices -  we have honeywell Devices.
Which XML Code did you use Oskar R.?

It says screen is pinned, unpinning is not allowed. Cant use the Buttons or the Status Bar - we also have that home button icon.
Seems to be that the Launcher is pinned - cant see system messages like SIM-PIN or Status bar.
0 Kudos
VegardAarseth
Enthusiast
Enthusiast

Oskar R. Please respond! I really need help with this. UEM support is not helpful.
0 Kudos
OskarRodriguez
Contributor
Contributor

Hi,


Sorry, but I did not get a notification when something was happening in this thread.
When an incoming call is coming when the phone is active, it is actually the status bar that is showing the incming call.


Add this as a custom setting. ( I have added off button as well)


 <characteristic type=' com.airwatch.android.androidwork.launcher'  uuid=' 568bc89d-1df8-4ce9-a041-e5a24acdb7ec' >
<parm name=' SkipCosuSetup'  value=' True' />
<parm name=' AllowStatusBar'  value=' True'  />
<parm name=' AllowPowerOff'  value=' True'  />
</characteristic>


 


 Hope this helps you. ๐Ÿ™‚


0 Kudos
admin
Immortal
Immortal

With the phone answering issue, you just need to allow the system app used for that specific process.


To fix this, you will need to add the system app used on the device for that specific function. You will need to add this on your launcher profile via Miscellaneous and add it to hidden apps.


For example, you need to enable phone calls. Samsung uses 3-4 system processes with their phone app.


com.android.phone
com.samsung.android.incallui
com.samsung.android.dialer
com.samsung.android.app.telephonyui


This will then

0 Kudos
VegardAarseth
Enthusiast
Enthusiast

Looks like your post is missing some text?

How do you enable OEM settings on the profile?

I did not know about the com.samsung.android.app.telephonyui, the rest I have added. I'll test.

0 Kudos
MarvP
Contributor
Contributor

Thanks Oskar R. you fixed my problem with the Statusbar!


<characteristic type=' com.airwatch.android.androidwork.launcher'  uuid=' 568bc89d-1df8-4ce9-a041-e5a24acdb7ec' >
<parm name=' SkipCosuSetup'  value=' True' />
<parm name=' AllowStatusBar'  value=' True'  />
<parm name=' AllowPowerOff'  value=' True'  />
<parm name=' AllowNotificationBar'  value=' True'  />
</characteristic>


This enables the Status bar and Notification Bar in Android for Work Launcher Mode, and also removes the homebutton Icon from the Launcher.
Thanks to Oskar!!


 


 


0 Kudos
PeterMohr
Contributor
Contributor

The full specs are here: https://docs.vmware.com/en/VMware-Workspace-ONE-UEM/1907/VMware-Workspace-ONE-Launcher/GUID-AWT-AFWP...


and remember this:


Be sure youโ€™re using the right characteristic type for your profile type:



  • For Android profiles, use characteristic type = ' com.airwatch.android.androidwork.launcher'


  • For Android (Legacy) profiles, use characteristic type = ' com.airwatch.android.kiosk.settings'

0 Kudos