VMware Workspace ONE Community
AndrewMolyneux
Contributor
Contributor
Jump to solution

Samsung KNOX and Group ID

Hello experts,
I am trying to setup KNOX to automatically fill the Group ID prompt I get during the enrollment with Airwatch (or Hub as it is called now).
However I cannot make it work with the JSON data.
Let's assume my Group ID is abc. I tried with this JSON Data {' gid' :' abc' } and {' groupid' :' abc' } but still always prompts me for Group ID.
This is the Group ID in authentication before I get prompted for my credentials to authenticate in the MDM Server URI.

Any advice?
Labels (1)
1 Solution

Accepted Solutions
LukeDC
Expert
Expert
Jump to solution

{' groupid' :' YOURID' } works for me


View solution in original post

Reply
0 Kudos
7 Replies
LukeDC
Expert
Expert
Jump to solution

{' groupid' :' YOURID' } works for me


Reply
0 Kudos
LukeDC
Expert
Expert
Jump to solution

Maybe your enrollment settings in the console are set to ask the user to choose a group?
Reply
0 Kudos
Neolyth
Contributor
Contributor
Jump to solution

Same here, both gid and groupID work with the group ID. Depending if you do work profile or work managed, of course...
Reply
0 Kudos
AaronTweed
Contributor
Contributor
Jump to solution

mine is inputted in this format {' gid' :' GroupID' } which works
Reply
0 Kudos
AndrewMolyneux
Contributor
Contributor
Jump to solution

Amazingly, if I put {' groupid' :' abc' } it doesn't work, but it I put it in Uppercase, it works. So {' groupid' :' ABC' } works.
Weird but works.
Reply
0 Kudos
NGeorge2019
Contributor
Contributor
Jump to solution

{' groupid' :' AndEnt' }   this is ours.. However that has been working fine for the past 9 months since we introduced devices in Samsung Knox. However yesterday people are getting new Samsung Phones, it is prompting them to enter GroupID all of a sudden. I have no idea if anything changed.

So it is groupid or gid
Reply
0 Kudos
admin
Immortal
Immortal
Jump to solution

It is case sensitive.

Reply
0 Kudos