VMware Workspace ONE Community
BarbraConner
Contributor
Contributor

Samsung Galaxy devices running Android 10 problem with AE webclips

Hi all - Last fall we reported an issue with Android 9 and Samsung devices where webclips from the Catalog (including the Catalog itself) would not be visible on the device.  The webclip shows as installed in the Catalog but is not visible.  This turned out to be a Hub issue which was resolved in Hub 1911. 

Now I'm finding that we have a similar situation with webclips and Samsung Galaxy devices running Android 10.  New enrollments are unable to get webclips delivered in the work partition.  Oddly enough if you enroll the same device in legacy, without AE, webclips are fine.

Does anyone have any insight or reported any similar issues?
Labels (1)
7 Replies
Jmosh
Enthusiast
Enthusiast

Hey Barb!

This is expected behavior with AE. You'll need to go into apps & books > public > add app > Platform = Android > Search Play store > Then click 'web apps'. Then tap the + in the bottom right.

From there you can set the title, url, display, icon etc. After thats done you can assign it out as if its an application.

- Jeff
BarbraConner
Contributor
Contributor

Thanks for the response Jeff.  But, why am I seeing different behavior on Android 9 vs 10?  I actually see the webclips in the Catalog and can request installation and they say they are installed but actually are not.  Will your recommendation resolve that?
Reply
0 Kudos
BarbraConner
Contributor
Contributor

And one more...they are added to the AE Catalog and are visible as available apps but the web clip does not install as an app
Reply
0 Kudos
Jmosh
Enthusiast
Enthusiast

Re the 9 vs 10, thats a great question! Assumption is that its related to deprecated API's, but i could be way off.


We actually use an app group to whitelist these apps combined with an App control profile for AE devices. This forces those apps to come down during enrollment. the only flaw with this is the app control profile has to be removed before any app thats added to the app group can be removed/uninstalled.


Reply
0 Kudos
BarbraConner
Contributor
Contributor

Jeff - I was able to get this to work on our stage environment so we have done something wrong on Production.  Thanks for throwing me a bone.

One more question.  These web clips show up as shortcuts on the home screen rather than as apps in the work partition.  Does your method change that behavior?
Reply
0 Kudos
Jmosh
Enthusiast
Enthusiast

Hey Barb,

Yes it does! With the app control + profile piece it will install the ' app'  within the work partition. Users can 'add to home' it they like.
Reply
0 Kudos
BarbraConner
Contributor
Contributor

You're a rock star!  Thanks so much
Reply
0 Kudos