Contributor
Contributor

Pixel Enrollment under Android 10 OS with Airwatch Hub

HI,

Checking out there to see if anything has run into issues trying to Enroll an Android Pixel 2 or 3 into Airwatch via the HUB App.  We are trying to do this at our company and we keep getting an error that states: ' failed to create the install url' .  This happens right after the user chooses the option that their phone is company or employee owned.

This is only happening on the Pixel devices that have the new OS 10 from Android.

Thanks
Labels (1)
18 Replies
Contributor
Contributor

Hi Lauren,

Are you running Android Enterprise in the Group you are enrolling the Pixel to?

Regards,
Diego
0 Kudos
Contributor
Contributor

I have no idea honestly. How would I check that?  I am an administrator of the application but am new and don't have much experience with it.
Thanks
Lauren
0 Kudos
Contributor
Contributor

Ok, investigated that a little. We do not have Android EMM Registration setup.
0 Kudos
Contributor
Contributor

We saw this issue yesterday as well on two devices.  After opening an INC with VMWare the issue was suddenly resolved.  We made no changes in our environment at all, nor did we update any of the hub apps on the devices. 
0 Kudos
Enthusiast
Enthusiast

You'll have to get Android Enterprise enabled. Android 10 and later no longer support the old 'Device Administration' enrollment method.
0 Kudos
Contributor
Contributor

We are also experiencing this issue today as well, but we do have Android Enterprise configured and always has been since we implemented Airwatch.  Does the console have to be a certain version to support Android 10?
0 Kudos
Contributor
Contributor

Allison, I am wondering the same thing about the console version as well. Thanks for the feedback everyone. I am guessing we need to upgrade our console and enable Android Enterprise to support Android 10. I will update as I find out more. If anyone else finds out more please update as well.

thanks so much!!
0 Kudos
Contributor
Contributor

David, we don't have EMM enabled in our console and enrollments are currently working. 

VMWare states you have to have at least hub v19.07.  Enrollments were tested in two on prem environments as well, on on 9.3, and one on 9.6 console versions.
0 Kudos
Contributor
Contributor

Last response from Airwatch support:
With the testing here I was able to recreate the issue which appears to be an issue with the seed script for Android OS devices.

I have already sent over a product issue report to get this addressed, but I have not heard back from them at this time
0 Kudos
Contributor
Contributor

Thanks Allison.  I haven't heard back from my support yet. The seed file being an issue is interesting though. Thanks for the info. I will do some checking into that also.
0 Kudos
Expert
Expert

I'm on console version 19.03 and didn't experience any enrollment issue with Pixel with OS 10.

However, we did experience mail sync issues on devices that were enrolled previously and were upgraded to OS 10.
0 Kudos
Enthusiast
Enthusiast

Lauren to my knowledge you should be able to enroll an Android 10 device in both ' Legacy'  or ' Android Enterprise'  mode but David is correct Android 10 does not support Device Admin any more so enrolling in to ' Legacy'  is not idle and most companies would probably consider it a security risk. The 1907 version of the console actually enables a pretty slick tool for migrating your users over to Android Enterprise so you might want to check that out.

https://docs.vmware.com/en/VMware-Workspace-ONE-UEM/1907/rn/VMware-Workspace-ONE-UEM-Release-Notes-1...
0 Kudos
Contributor
Contributor

Hi all, So it turns out the issue was caused by a seed file that needed to be updated. After placing the ticket with AirWatch they sent us the update. Our database team ran it against our database and now we are able to enroll pixels again.

Also, we don't have the Google EMM setup so that wasn't an issue. We are also running console version 9.6 so that wasn't the issue for us either.

Thanks for the feedback everyone and I hope this helps.
0 Kudos
Expert
Expert

Glad to hear Lauren.

Just curious, any particular reason why you are still on console 9.6?
0 Kudos
Contributor
Contributor

Did Airwatch release the seed script to fix yet. I am running 1811 and am having this issue on Pixel and Samsung devices on Android 10?
0 Kudos
Contributor
Contributor

Hello Chaim,


the OS Seed Script is continuously extended for older WS1 versions.


You'll need it for Android10 with WS1-1811. It can be downloaded here: 


https://resources.workspaceone.com/view/gcbjqx3jlwq5krkx9v3p/en


(Yes, the script is officially about Apple OS updates, but it includes and updates all supported operating systems - including Android10)

0 Kudos
Contributor
Contributor

Hi,

We are on console version 20.01 and having similar issues on Pixel devices.

1. Can you share the seed script.

2. Any specific thing AirWatch Support mentioned about the issue? Like DB entry not present for Android 10/11.

Thanks.

Regards.

0 Kudos
Enthusiast
Enthusiast

I experienced the same issue on pixel device that are running OS11. We are On-prem running 2001.

The error is cause by the DB not having the OS file that matches the enrollment of the device. To resolve this you will want to run the latest OS seed script file to update your DB. The file contains all OS updates, but if you want to confirm what's within the file you can open it with notepad ++.

OS Seed Script: https://resources.workspaceone.com/view/gcbjqx3jlwq5krkx9v3p/en

If you are not sure about the seed script, I suggest opening a ticket with VMware as they are aware of this issue.