Atulp8
Contributor
Contributor

Intelligent hub notification disabled in settings

Jump to solution

Hi

i am new to workspace one. I have configured Salesforce and ServiceNow in workspace one to receive notification in Intelligent hub. everything seems to be Fine right from UEM to ws1 access and intelligent hub including sso. However, I am not getting notification on intelligent hub from backend. When I look at intelligent hub settings - notification is disabled and it does not allow me to enable the same.

pl suggest what settings need to be done to correct it ... pl see screenshot

1 Solution

Accepted Solutions
ogushia
Enthusiast
Enthusiast

From your screen shot, I think your WS1 Access Client Template name is not valid.

Template name have to be exactly [MobileFlows_Server_Template] like below because Hub request the template named that.

pastedImage_0.png

View solution in original post

8 Replies
ogushia
Enthusiast
Enthusiast

It seems you want to use Mobile Flows.

Check out Techzone for a demo movie on how to enable and configure the Mobile Flow ServiceNow Connector.

https://techzone.vmware.com/vmware?share=demo2068

You can see a detailed explanation of Mobile Flows in the video above.

regards

0 Kudos
Atulp8
Contributor
Contributor

I followed same instructions from Video. However, notifications are not enabled. I went through few more Articles and learnt that in workspace one access-> catalog -> settings -> Remote app access -> client -> create client

And I can enable service client token in workspace one access. Using that I was able to send sample notification on intelligent hub through postman. But I am not able to make out how to set configuration between service client and workspace one UEM/mobile flow to get notification on intelligent hub ...

am I missing anything ?

0 Kudos
ogushia
Enthusiast
Enthusiast

Please tell me what happens when you tap the switch of Servicenow notification.

you should be redirected to ServiceNow Oauth authenrtication page.

pastedImage_2.png

0 Kudos
Atulp8
Contributor
Contributor

Thanks for the prompt response. Pl see attached snapshot

0 Kudos
ogushia
Enthusiast
Enthusiast

From your screen shot, I think your WS1 Access Client Template name is not valid.

Template name have to be exactly [MobileFlows_Server_Template] like below because Hub request the template named that.

pastedImage_0.png

Atulp8
Contributor
Contributor

Precise response .. thanks!!

0 Kudos
Atulp8
Contributor
Contributor

Can you please help me understanding one more point.

I am trying to create a custom connector in UEM -> Content -> Mobile Flows - > My Flows -> Create

As soon as I enter discovery URL I get an error "Discovery URL could not be validated". My public facing API URL is correct. My server logs shows request status 200 OK.

Do I need to do any settings in Workspace One for Mobil flow to recognize my connector?

Any help is appreciated …

0 Kudos
ogushia
Enthusiast
Enthusiast

Hi,

Honestoly, I have never tried Custom Connector yet.

Instruction and trouble shooting guides are available at below link. (maybe you have already checked.)

https://github.com/vmware/connectors-workspace-one

I think when we setup Discovery URL, WS1 UEM not just check that the URL is reachable, but check that desired response is coming back.

pastedImage_0.png

Regards

0 Kudos