Isty1974
Contributor
Contributor

Failed to update Windows Firewall for BLAST.

If You disabled the integrated windows firewall, you should get this following error message, but fortunately the installation success!

1: Failed to update Windows Firewall for BLAST. Please contact your administrator for the support.

VIEW_HORIZON FW. BLAST ERROR.jpg

I've found something on VMware Horizon View 5.2 Feature Pack 1 Windows Release Notes at known issues, but I think this isn't a direct solution for this warning...

Horizon View and Blast Secure Gateway

  • If you change the VMware View Blast Secure Gateway (absg.log) log level on a View Connection Server instance from Info to Debug, the log level remains Info. (You change the log level by opening the Set View Connection Server Log Levels on a View Connection Server instance, changing the absg log level, and restarting the VMware View Blast Secure Gateway service.) Changing the log level from Debug to Info works properly.
    Workaround: None.
0 Kudos
6 Replies
Linjo
Leadership
Leadership

You are not really stating your exact problem but I suspect it does not work after the installation?

Is the Windows Firewall service running?

// Linjo

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
Isty1974
Contributor
Contributor

Firewall has been disabled. But working fine. It was just a scary warning message! :smileygrin:

0 Kudos
ijeevan23
Contributor
Contributor

I am encountering the same issue, I get 1: Failed to update Windows Firewall for Blast and am not successful connecting VDI using HTML access. (Firewall is ON on the View Connection Server)

Telnet between View Desktops and View Connection using port 22443 server fails.

I could see no port esablishment for 22443 while running netstat -a on the View Connection server.

Anyone have fix to this problem, will certaily value.

Thanks.

0 Kudos
MMAgeek
Enthusiast
Enthusiast

windows firewall needs to be enabled on the parent virtual machine for the installer to complete - it creates a firewall rule inbound to allow blast. Check that the blast rules have been enabled into the windows firewall on both parent virtual machine and also on the view connection server - i recall having to manually enable the rules on the VCS before

0 Kudos
CHibbard
Contributor
Contributor

Hello,

We disable the windows firewall as part of the domain policy for servers. I'm not understanding why we would need to turn it ON for Blast to turn it OFF for this port to work, but this is what my engineer is telling me. The service is enabled, but the firewall is off. Any info is appreciated.

0 Kudos
MMAgeek
Enthusiast
Enthusiast

I'm unsure why exactly blast needs the firewall enabled, but with an exception to allow the traffic. However this is what it states in the admin guide, and for various customers of mine who have faced the same issue enabling the firewall and then the blast exception has resolved the issue.

Most of my customers are only using blast externally with View Security Servers, which also require that the connection server has the firewall enabled  anyway, to create the IPSEC tunnel between connection and security server. You could put your Connection servers in their own OU and create a new group policy to enable the firewall just for these servers

0 Kudos