ChaiseCooperCha
Contributor
Contributor

Error Code 12064 Could not retrieve license for the app with iTunes Store ID

Doing some testing within AirWatch/WorkSpace and am running into this error when trying to automatically distribute a number of apps, but for the purpose of this forum thread, I'll use the VMware WorkSpace ONE app as the culprit. Note this doesn't appear to affect ALL apps.

I've allotted enough licenses.
Device Based Assignment is turned ON.
The app is compatible with the device and iOS version.
Application syncing with ABM is working fine.
Certificates are all up to date.
When I try to push the app manually from the device itself and the devices page in AirWatch, it fails.
Labels (1)
21 Replies
BendikSygnestve
Contributor
Contributor

Yes 

0 Kudos
RicardoPachecoR
Enthusiast
Enthusiast

Hello, 

We have a Shared SaaS, latest version. Today, I kept on getting the "12064 Could not retrieve license for the app with iTunes Store ID 298844###." error. No matter how, what I tried, same result.

I have learned that the easiest solution is to wipe the devices (corp owned iPads), with a generic (staging user). That may take 10 minutes, but I don't have to baby sit the process. I have an Automator workflow set to identify connected devices, erase them, and push them through automated enrollment. 

Since this is the solution, I assume that AW gets confus-cabulated and losses its marbles with license assignment. When the device comes back through the enrollment process, the correct license is applied. 

While not a solution, which I have very low hopes for AirWatch support, this is a workaround that has helped me. 

Hope this helps some of you too. 

0 Kudos