Chris_USS
Contributor
Contributor

Enrolling Employee Owned Samsung devices for Android for Work BYOD

Jump to solution
We are starting to implement BYOD at our work, and I have managed to configure Apple and Android (using AfW) to use BYOD based implementations.  However, I have been unable to enroll Samsung devices. 

When I go through enrollment on a Samsung device (done this on two different devices) it gets to Please wait while we process the Enterprise EULA, then it pops up a toast message ' Failed to validate the product key.'  then a second message ' Samsung KLM license activation has failed either due to an invalid license or a faulty network connection' .

I have signed up for Samsung KME, but I am worried based on the instructions that enrolling devices are going to change ownership to the company.  These are employee owned devices, and should remain for the employee. 

In Airwatch, I see the Samsung KNOX license key option, but I'm having a hard time finding instructions on how to appropriately receive a license key.

Anyone have some guidance on what I need to do to achieve my goal?  Am I stuck having to use Samsung's EMM solution?
Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Boe_K
Enthusiast
Enthusiast
Chris I'm no expert by any means but it sounds to me like you enabled Samusng's Knox setup and not Android Enterprise (formerly Android for Work). We have are also using Android Enterprise for BYOD and have hundreds of Samsung Devices setup and I have never needed to enter a Samsung KME License.

I would recommend reading the Android Platform Guide I've linked below as all you should really need to do is link your WS1 with a dedicated Google Account which is used to managed Work Approved Apps.

https://docs.vmware.com/en/VMware-Workspace-ONE-UEM/1902/WS1_Android_Platform.pdf

View solution in original post

0 Kudos
5 Replies
Boe_K
Enthusiast
Enthusiast
Chris I'm no expert by any means but it sounds to me like you enabled Samusng's Knox setup and not Android Enterprise (formerly Android for Work). We have are also using Android Enterprise for BYOD and have hundreds of Samsung Devices setup and I have never needed to enter a Samsung KME License.

I would recommend reading the Android Platform Guide I've linked below as all you should really need to do is link your WS1 with a dedicated Google Account which is used to managed Work Approved Apps.

https://docs.vmware.com/en/VMware-Workspace-ONE-UEM/1902/WS1_Android_Platform.pdf
0 Kudos
Chris_USS
Contributor
Contributor
Boe, Thanks for the response.  I think I found my issue - I had the Samsung Containers Enabled on the OG's Intelligent Hub Settings.  I disabled this setting and have gotten further.  Now I'm just waiting on the device to encrypt.  But your right, it was still using Samsung Knox with that setting (There isn't a simple ' Enable/Disable Knox settings'  option, its individual options that may turn it on).
0 Kudos
Boe_K
Enthusiast
Enthusiast
Hey Chris that makes sense, we just linked our Google account and took the rest of the defaults as we didn't have any other specially needs. Hopefully turning that off takes care of your issue and you will also see a reference to Knox on Samsung devices since its built into the OS but everything else will just be plain old Android Enterprise.
0 Kudos
Chris_USS
Contributor
Contributor
Yeah, I was hoping the same, but I inherited this environment from someone else, so I've had to make additional adjustments here and there that I wouldn't have expected.

Thank you!
0 Kudos
JacquesPerrolle
Enthusiast
Enthusiast

Ah, thank you, this was my problem too!

For those that might find this in the future, enrolling a Samsung device was stuck at "please wait while we retrieve your enterprise settings". Turns out, as noted above, the problem was in:

Devices & Users > Android > Intelligent Hub Settings

Under Samsung KNOX, "Enable Containers" was Enabled.  Disable that and started enrollment over, and it worked as expected.

Thanks Chris_USS!

0 Kudos