RonTom42
Contributor
Contributor

Desktop Client automatic login

Hi!

I´ve set up kerberos in Horizon Workspace and it works with automatic logon in Internet Explorer.

I´ve also installed the Desktop Client in a View desktop. In this View desktop pool the users have a separate user profile. And when they log in for the first time, they have to click the Horizon Workspace Desktop Client taskbar icon to authenticate. The authentication runs through automatically using kerberos. Now the user won´t have to click the icon when later logging on the view Desktop pool with the same user profile.

I would like the Desktop Client to do the automatic authentication even the first time that a user logs on (with a empty user profile). Does anyone know of a parameter that I can pass to the Desktop Client or any other option that I can set to achieve this behavior?

8 Replies
tgerber
Contributor
Contributor

We are looking to do the same thing.

0 Kudos
darrenprior
Enthusiast
Enthusiast

Same issue here, sso on floating desktop pools should be a default option.

0 Kudos
admin
Immortal
Immortal

thanks all, I'm currently inquiring about this internally, I'll update here if I have any update, thanks!

ThoLar73
Contributor
Contributor

Any news on this topic? I'm facing exactly the same issue on my brand new 1.8.1 Horizon workspace.

We had a VMware consultant on the issue, but he wasn't able to fix it.

When the users have clicked the icon the first time, they never have to do it again afterwards. It just Works as intended. But the first time is the problem.

Kind regards

0 Kudos
oliii
Contributor
Contributor

Hi,

Did you enable NTML? After enable it, it works for me.

09-07-2014 13-06-03.jpg

0 Kudos
RaviChayanam
VMware Employee
VMware Employee

Can you please send your logs (you can generate them by clicking on Collect Diagnostic Information on your Client systray app) via a private message?

0 Kudos
ThoLar73
Contributor
Contributor

Thanks for replying!

NTLM is activated, so that should not be the issue.

Just to make sure I explained it correctly.... It's only the first time a user with a blank profile logs on, he/she has to to click the icon.

Once he/she clicked it, they will be automatically signed in every time they logon to the VDI.

So it's only the first time with an empty profile I have the problem. are there any way I can avoid this?

0 Kudos
RaviChayanam
VMware Employee
VMware Employee

Hi ThoLar73,

Can you try the following? After logging in to your Desktop, wait til "Sign into Workspace" message appears and then quit Workspace client. Launch the client again, then lets see if it automatically signs in.

In both cases, can you please send your logs (you can generate them by clicking on Collect Diagnostic Information on your Client systray app) via a private message? The logs will tell us more about what might be happening here.

What switches did you use if any while installing the client on to your view template/snapshot?

0 Kudos