VMware Workspace ONE Community
LukeDC
Expert
Expert

DEP reliability

Anyone else having a real reliability issue with DEP/ABM lately? I don't think it's Airwatch as I am also having issues where it won't let me add devices via AC2 on occasion as well. I really feel like Apple is having issues they are not revealing.
Labels (1)
Reply
0 Kudos
36 Replies
HugoCampo
Contributor
Contributor

Yes i have been noticing the same strange DEP issues we have ASM. Devices don't unassign or take a few hours to sync over. i have one duplicate entry already on the AirWatch side that im attributing to this DEP problem. Devices still enroll though...
Reply
0 Kudos
VanceFryer
Contributor
Contributor

I've not noticed any issues. I don't make a lot of changes -- devices are auto-assigned to AirWatch. Given the clunky feel of ABM, though, I'm not surprised.
Reply
0 Kudos
DennisGauthier
Contributor
Contributor

We have the same issue with DEP enrolling duplicates to some devices. The only fix we have found, temporarily, is to do the following:
1. Batch upload your devices to the console
2. Confirm the upload and assignment in Lifecycle
3. Assign a DEP profile to the device(s)
4. Log into Apple Business Manager, and assign the devices to your server


5. Go back into your console and Sync Assets.  Confirm the device is still in LifeCycle and not duplicated.


6. Assign a DEP profile to the device(s) AGAIN.  (You may find that the DEP profile is no longer present after the sync)


Only after completing these steps were devices able to enroll properly. Before that, we would get duplicates and sometimes they would enroll as a staging user instead of the intended user.


Also, if you have duplicates, remove them in Lifecycle by un-assigning the devices in ABM, and then Sync Devices with Apple in the console.
Then complete the steps listed above.

Reply
0 Kudos
ChristineDratva
Contributor
Contributor

Same issues here.
I thought there might be a time limit on a DEP profil at the beginning, but that didn't really make sense.
Only solution I found, is removing and reassigning the profil.
Haven't found any duplicates yet ...
Reply
0 Kudos
LukeDC
Expert
Expert

There is a known issue with the Apple API as of now and WS1 support is working on it. I have an open ticket.
Reply
0 Kudos
JohannZandanel
Contributor
Contributor

Hello all,

We have also someduplicates in our Airwatch system. If there is a known issue with the Apple API and W1: any idea how to get the information when the fix is solved? And how to eliminate the duplicates?

Thank you for any information

JZ
Reply
0 Kudos
GeraldHubbard
Contributor
Contributor

Since the iPhone XS released, we've had nothing but issues with our DEP phones.  It's localized to new iPhone XS enrollments.  Everything from invalid profiles during enrollment to devices not syncing even after a manual sync on our console.  WSO UEM 9.5.0.16.
Reply
0 Kudos
PatrickStormink
Contributor
Contributor

We are experiencing the same issue more and more often.
Invalid Profile errors during setup. It used to be maybe 1-3 out of 100 now it seems more like 10-20 out of 100 with this problem. We haven't touched the DEP Profile in ages, so the issue isn't due to any config alterations. Also, the same iOS-device with this profile issue will suddenly work fine after a factory reset.
This is a major issue for us since we send devices all across Switzerland and expect the users to set their iPhones and iPads up themselves. If they happen to receiver a problem device, we cannot expect them to reset their device with iTunes or Apple Configurator. In one case we went through 3 iPhones with the same user.
I even tried to open a ticket with Apple - but they aren't any help unless you shovel cash for a support contract over to them. Apple Switzerland's lead engineer said he had never heard of this problem, which I highly doubt. Useless.
I’m really looking forward to Workspace ONE supporting COPE-Mode for Android so we can finally kick iPhones out.

Reply
0 Kudos
DmitriAltum
Contributor
Contributor

Patrick,
We are in the same boat. I've seen a huge leap in the Invalid Profile errors in recent weeks which is becoming a huge problem as we too ship devices all over (though the US/Midwest not Switzerland). I've reached out to our Rep to see if he can find any internal information (though we all know how tight-lipped Apple loves being)
Reply
0 Kudos
GeraldHubbard
Contributor
Contributor

We've suspended assigning a DEP profile to phones until Apple or AirWatch address the issue. 
Reply
0 Kudos
RyanBradley
Contributor
Contributor

I only seem to be having trouble with one XS (mine, as it happens) that I bought from a brick and mortar store, that I'm trying to get into AW via DEP(ABM) using AC2. That one produces duplicate entries in AW.
The other XS purchased from Apple (and enrolled before it was shipped), worked perfectly.
I've sub'd to the link Luke supplied.
Reply
0 Kudos
RobertBolton
Contributor
Contributor

We also have duplicates, invalidate profiles, wrong device information in the AW admin portal, DEP and VPP sync errors in AW.  This is a mess and I have opened several tickets with AW and even a ticket with Apple but no resolutions, only guessing from support.     
Reply
0 Kudos
_ARI_
Contributor
Contributor

Reply
0 Kudos
MichaelDeeken
Contributor
Contributor

We also discovered that when devices are added to DEP via AC2 and then moved to the main DEP group, they won´t sync into WS1 until you remove them from DEP. Once done, the sync for those is completely messed up. (you have to remove devices from DEP to transfer them into WS1 and vise versa). Furthermore, invalid profile errors slowly rised during the last 2-3 months
Reply
0 Kudos
fitzpat_e
Contributor
Contributor

We're seeing Invalid Profile errors too. Asking users to Factory Reset the device using iTunes is just terrible but the only way we can get them up and running. Users are posting new DEP iPhones back to us. We're also seeing sync issue and unable to remove registered devices in Airwatch if they are gone from Apple DEP  I don't think we would have used Apple DEP if we had known these issues existed. Self enrolment via Agent never gave us this trouble
Reply
0 Kudos
RyanWampler
Enthusiast
Enthusiast

We are having the invalid profile issues too.  From what I'm hearing, it has become pretty common over the last few weeks.  No idea if the issue lies with AW or with Apple.
Reply
0 Kudos
DmitriAltum
Contributor
Contributor

Apple is having a Business event in my area next week and supposedly will have a few engineers there. Having worked for Apple and being able to attest to their ' tight lipped'  attitude, I don't imagine I'll get much but I definitely plan to grill them on it and find out if it is something they are at least aware of internally.
Reply
0 Kudos
AaronVanNorman
Contributor
Contributor

This is from the iOS 12.1 beta notes:  MDM enrollment is more reliable, solving a problem that could cause enrollment to fail with an ' Invalid Profile'  error and another that could cause the device to stop responding to management after enrollment.
Reply
0 Kudos