VMware Workspace ONE Community

Autopilot Automated Enrollment into WS1 only working for certain Users

We have AAD integrated with WS1 so we can use Autopilot and its automated enrollment feature for our Windows 10 devices. the integration works great for me and several others but I've also had people like our IT director and a few other IT team members try setting up a Dell computer enrolled in Autopilot but they get the following error "Unable to find user in Active Directory. The affected users do exist in AD and we can also search for them successfully when testing the LDAP connection in UEM. We've tried a few different immutable ID's to see if that was the issue but they always get that error after inputing their email and password. Just wondering if anyone has experienced a similar issue

IMG_1847 2.JPG

Labels (1)
0 Kudos
2 Replies
VMware Employee
VMware Employee

This error has to do with a mismatch between AAD Mapping Attributes (ImmutableID) more details can be found here: Enrolling Windows 10 Devices Using Azure AD: VMware Workspace ONE UEM Operational Tutorial | VMware



I just wanted to let you know that I ran into the same issue. A description of the issue and how I fixed it can be found in my blog post.

VMware Workspace ONE - Fixing the "Unable to find user in Active Directory" issue · ivandemes.com


\\ Ivan
Twitter: @ivandemes
Blog: https://www.ivandemes.com