jerk_store
Contributor
Contributor

Android for Work - Device based - Skype doesn't get app permissions?

Appreciate any responses...

Have Android for Work deploying via Device Based enrollments.  Bump device via nfc, enrolls fine.  Apps get delivered, MDM working, using most apps, get to skype...launch and it tells me I need permissions.  Go to settings - Apps and Notifications - skype - permissions - message saying app is controled by admin, and it looks like it should work, but the 'hub' message, says it is not allowed by administrator.  Do have skype added to whitelist, just in case. Devices are set to Company Owned - User account role is full...app is approved...org group and profiles all get delivered successfully and MDM commands work fine.  App is added to google work account and approved...shouldn't I be able to use this app?

Please tell me there is a restriction or something I forgot to check to use apps like this...
Labels (1)
0 Kudos
4 Replies
jerk_store
Contributor
Contributor

In case anyone has this issue in the future.

The fix is to load the app in a different manner...so in this case, load the Skype APK as an internal app, and it worked fine.  From what I was reading, it may have to do with a key that gets generated during installation if a device is considered 'Rugged'.  There is not a lot out there about this.
0 Kudos
jerk_store
Contributor
Contributor

Using the alternative version of the app did not seem like a good solution, so I actually tried what I first thought was the fix, to deploy a 'Permissions' payload with it set to 'Grant all apps' permission.  This actually did not work consistently, but when the apps were added as exceptions, and set all of the settings to 'Grant', it worked.  Tested many scenarios, all worked when it was set this way.  Waiting to hear from AW support to confirm this or if they suggest something else.
0 Kudos
BDBos
Enthusiast
Enthusiast

Hi George! I just see your message and can confirm the problem you are experiencing. We also use Workspace ONE, but have encountered this problem in a scenario where we only manage devices with Google Apps (Device Policy) (ie no Workspace ONE). The problem occurs as far as I have been able to trace only for with Android version 8 or higher. Within the Google Apps engine, the solution was to disable the automatic acceptance of permissions, and allow the user to manually activate the permissions. If you then do a new deployment, it works (and after manually accepting the permissions). I understand from your story that if you add the App as an exception, it also works? Good to know! So this seems to be not a Workspace ONE problem, but something with the Skype client.
0 Kudos
J4yJ4y
Enthusiast
Enthusiast

Hi George,

Just to let you know this thread helped me out for AE Work Managed device.
I was not able to have the user opt out of location service permission for the Intelligent Hub App.
By adding it as an exception in the permission payload of the device profile, the end user now can disable the permission .
Thanks!
0 Kudos