VMware Workspace ONE Community
syarbrou
Enthusiast
Enthusiast

Android and System UI being blocked with launcher

We have some Zebra devices that are using launcher.  We have one app that is in the launcher screen.  That app launches several other apps.  All internal deployed apps.  The other apps are all included as hidden apps.  When the core app tries to launch the other apps they launch however at some point in using the app they are seeing a message "Your IT admin has restricted access to the app –System UI”.  From my reading then System UI is the "name" of the app but looks like it's an android framework of some kind more than an app.  Any ideas what's going on?

Thanks.

Steve

Labels (2)
Reply
0 Kudos
8 Replies
AngelsGuardian
Contributor
Contributor

The most pinpoint search on my actual issue and no answer, this is sad 

odisjohnson
Enthusiast
Enthusiast

Did you ever get this answer?

Reply
0 Kudos
AngelsGuardian
Contributor
Contributor

Never got an answer no BUT, i learned a lot since then and i can troubleshoot and fix my issues better.
Knowing to work with packages and actions is the key.. do you have an issue ?

Reply
0 Kudos
SEBGR44
Enthusiast
Enthusiast

Good morning

In blocked applications there will be the id or activity that is blocked

Cordially

Reply
0 Kudos
RandyLahey
Contributor
Contributor

I am also looking for a solution to this issue. Sad that there hasn't been an answer in three years. 🤡

Reply
0 Kudos
odisjohnson
Enthusiast
Enthusiast

The solution that worked for me was going into setting within the Launcher on a device. Selecting Blocked Apps. Copying the package ID and creating a hidden app on the launcher with that package ID with in the console. You'll also have to add the package ID for App Activity as well. So, ultimately you'll add two hidden apps maybe more depending how many activities are listed under the blocked app. If that makes sense. 

RandyLahey
Contributor
Contributor

@odisjohnson Thank you for the response! 

I have the ID and activity and attempted to allow it via a different method than described to no avail. I'll try to add it as a hidden app and see how that goes. Thank you again!

Reply
0 Kudos
RandyLahey
Contributor
Contributor

To follow up on this, I was able to resolve the issue by adding a hidden app under the launcher (going to the profile, launcher, configure layout, hidden apps, then choose the "miscellaneous" quick filter, "add new" and used com.android.systemui as the "app id", saved/published and it worked perfectly.  big thanks to @_Steven & @callmegibby in the other thread and @odisjohnson in this thread for pointing me in the right direction. 

Reply
0 Kudos