Win server 2003 VM guest does not boot up

A little background here: I use this backup software "ShadwProtect" to backup my vm guest on one of my ESXIhost and restored it in another site's ESXI host.

The first time I boot up, I faced an error "Error on boot: "STOP c0000135 unable to locate component csrsrv.dll not found reinstalling the application may fix the problem".

After trying out for days, I figured from forum that there is a conflict in one of the Windows Updates for virtual environment (Source: https://goo.gl/wrssyO) , that KB3045999 caused this problem for them and upon uninstalling this win update, they managed to boot up successfully. For my situation, it was a VM in ESXI and I totally could not boot into normal windows at all. So I bootup using Windows 2003 Recovery CD ISO and managed to get into the CMD. What I did was deleting the problematic KB using CLI.

"C:\Windows\$NTUninstallKB3045999$\spuninst\BATCH spuninst.txt"

This command is to uninstall the KB from the OS itself (Source: How to uninstall a hotfix or Service Pack via the Recovery Console?).

After doing so, I rebooted and it no longer get the error above. But instead, it seems to freeze when loading Windows.

After which I did a chkdsk /r but to no avail, still getting the same freeze.

What I noticed is that I am able to get into normal safe mode, but not Safe Mode with networking or Safe Mode with cmd prompt.

I have tried everything I could but I have run out of ideas.. This is driving me insane!

I have managed to Download the vmdk file from the original site, the file I copied out got an additional "xxx-flat" in it.. the additional flat word.. I have not tried to load the VMDK into my current VM yet..

Is there any advice that I can get myself out of this mess?

Sorry for the long winded story..

0 Kudos
0 Replies